Question Some apps just wont run on dedicated graphics

Sep 17, 2021
2
0
10
0
So i have an MSI laptop:

-nvidia gtx 1050 (dedicated graphics)
-intel i5-7th gen cpu
-intel hd graphics 630 (integrated graphics)
-windows 10

My issue: some specific apps just keep using the integrated graphics card, completely ignoring the nvidia graphics.

I have tried to:
-Set preffered graphics card for global settings to nvidia processor in nvidia control panel.
-Set preffered graphics card to nvidia processor for the specific apps in program settings in nvidia control panel.
-Changed physX configuration to nvidia processor in 3d settings in nvidia control panel.
-I also opened windows graphics settings and set the preffered perfomance mode to high performance for the specific apps (which uses the nvidia gpu.)
-Tried updating all drivers to the latest available
-Tried uninstalling drivers and reinstalling the latest ones

Literally every post on the internet says "nvidia control panel>3d settings>set preferred graphics card to nvidia" but none of these work.

-I can see a "Windows os now manages the selection of graphics processor" message in my nvidia control panel.
-There is no option for "run with graphics card) when i right click on the app.

These apps (namely brawlhalla and gta 5) completely ignore my nvidia graphics card and just use the integrated graphics even after me trying everything i found on the internet to make them use the dedicated graphics. I even resetted my whole computer and installed everything again, but nothing changed.

Any help is greatly appreciated
 

Giant Hunger

Upstanding
Jun 23, 2021
315
40
240
4
So i have an MSI laptop:

-nvidia gtx 1050 (dedicated graphics)
-intel i5-7th gen cpu
-intel hd graphics 630 (integrated graphics)
-windows 10

My issue: some specific apps just keep using the integrated graphics card, completely ignoring the nvidia graphics.

I have tried to:
-Set preffered graphics card for global settings to nvidia processor in nvidia control panel.
-Set preffered graphics card to nvidia processor for the specific apps in program settings in nvidia control panel.
-Changed physX configuration to nvidia processor in 3d settings in nvidia control panel.
-I also opened windows graphics settings and set the preffered perfomance mode to high performance for the specific apps (which uses the nvidia gpu.)
-Tried updating all drivers to the latest available
-Tried uninstalling drivers and reinstalling the latest ones

Literally every post on the internet says "nvidia control panel>3d settings>set preferred graphics card to nvidia" but none of these work.

-I can see a "Windows os now manages the selection of graphics processor" message in my nvidia control panel.
-There is no option for "run with graphics card) when i right click on the app.

These apps (namely brawlhalla and gta 5) completely ignore my nvidia graphics card and just use the integrated graphics even after me trying everything i found on the internet to make them use the dedicated graphics. I even resetted my whole computer and installed everything again, but nothing changed.

Any help is greatly appreciated
Theres this feature for Laptops to switch from integrated gpu to dedicated gpu for saving power. But if you want to fully use your dedicated gpu
  1. Navigate to Settings > Advanced tab.
  2. Navigate to Integrated Graphics Configuration.
  3. Set Initiate Graphic Adapter to PEG.
  4. Locate IGD Multi-Monitor and set it to Disabled.
 
Sep 17, 2021
2
0
10
0
Theres this feature for Laptops to switch from integrated gpu to dedicated gpu for saving power. But if you want to fully use your dedicated gpu
  1. Navigate to Settings > Advanced tab.
  2. Navigate to Integrated Graphics Configuration.
  3. Set Initiate Graphic Adapter to PEG.
  4. Locate IGD Multi-Monitor and set it to Disabled.
I tried opening bios > settings > advanced but the "integrated graphics configuration" setting is not visible
 

ASK THE COMMUNITY