Question Some games freeze for 2 seconds in the exact same way in random intervals (audio keeps going; I lose all input)

bp1696

Honorable
Oct 27, 2016
44
0
10,540
1
FYI, I made a similar thread to this months ago but never really found a solution. This time I have video though.

So anyway, I started having this issue back around June/July where I'll be playing a game normally, no performance issues, and then suddenly the screen/game will freeze for a half second, un-freeze for a half second, and then freeze again for another half second. During this time I lose all input (aka my character comes to a complete halt), and audio keeps playing totally normal. This happens in exactly the same way every single time it happens in several different games. Examples of games it happens in are Trails to Azure (shown in posted video), Resident Evil 2 Remake and Resident Evil 4 (and once again, it happens in the exact same way in all these games). Examples of games it does NOT happen in are Final Fantasy XIV, Rocket League and Deep Rock Galactic. The timing of when these freezes happen is completely random and not something I can replicate.

The only thing that's consistent about it is that it doesn't happen back-to-back very often. Once it happens, I'm usually good for anywhere between 5 minutes to 2 hours before it happens again. Occasionally I'll go entire gaming sessions without it happening, though that isn't very common.

Here is a video of it happening around the 0:24 mark (video link should be time-stamped though). This should be a decent demonstration of it as the graffiti makes it obvious to see.

Things I have tried:

-Completely uninstall graphics drivers and then do a clean install (twice)
-Check Task Manager (nothing is out of the ordinary when it happens)
-Check HWMonitor (all stats are normal when it happens)
-Whitelist gaming/Steam folders in Windows Security
-Disable audio drivers
-Close each and every third party software tool I have
-Several different alterations of Nvidia Control Panel settings
-Turning off Game Mode (or whatever it's called) in Windows settings
-Disabling the Xbox Game Bar in Windows Settings
-Making sure power management settings are at High Performance in Windows and Nvidia settings
-Unplugging all external devices from PC
-Completely disconnecting PC from the internet and removing the Ethernet cable (I was desperate, ok?)
-Windows Key+CTRL+Shift+B

I know I've done more, but I can't think of it all. Those are the key fixes I have tried, though. Does anyone have any other ideas? Thank you.

System (3 years old):

OS:
Windows 10
Motherboard: ASRock Z390 Phantom Gaming SLI/sc LGA 1151
CPU: i7-9700k
GPU: RTX 2070
PSU: EVGA SuperNOVA 650w Gold 80+
RAM: G.SKILL TridentZ RGB Series 16GB (2 x 8GB) 288-Pin DDR4
 

ASK THE COMMUNITY

TRENDING THREADS