Question Some games not launching/launch to black screen. Completely out of no where.

Nov 7, 2020
2
0
10
0
Hey guys. Really at my wits end with this so I hope someone can help. On Nov. 5 a very peculiar problem started happening on my rig... some games are freezing at start up, while others are working fine. I first noticed this when I tried to show a buddy of mine Watchdogs Legion. I started the game and the screen just stayed black. I can see the Watchdogs cursor, but nothing else. Huh, weird. I thought to myself. I just blamed it on the <Mod Edit> port and moved on to show him Control and it worked fine. So, I thought nothing of it. Later that night I downloaded Genshin Impact on a whim to try out and that did the same thing... white screen, see cursor, "genshinimpact.exe is not responding." crash. At this point I'm like what the ??? So I try Watchdogs again and the same thing happens as earlier - black screen. So I boot up Control.... and it works fine? I try and boot up Horizon Zero Dawn. Doesn't work. Dark Souls III: Works. Witcher III: Doesn't work. Red Dead II: Works. Destiny 2: Doesn't work.It doesn't make any sense.

All of these games worked the day before and I changed nothing. No new drivers... Windows update may have done something but I don't know? Anyway I formatted (twice) immediately to try and fix it but that did nothing. I completely uninstalled drivers with DDU but that did nothing. I tried my buddy's 1060, no change. I did a memtest that came back with nothing. I benchmarked just the online user benchmark and everything seems to be working great. Did a Prime95 CPU stress test for four hours with nothing. I have also manually installed DirectX, Microsoft Visual C++, etc... but nothing is helping. What do I do? Does this seem like a driver issue to you? Or hardware? It's so strange. I have also tried all the drivers including the 457.98 hotfix.


Specs:
Windows 10
Ryzen 5 3600x w/ Noctua NH-D15
RTX 3080 EVGA ftw3 Ultra 16gb
Corsair Vengeance LPX DDR4 3200 MSI Gaming Max b450 mobo

These KB updates:
4580364
4580419
4577266
4562830
4570334

I am just absolutely devastated. I finally get a sick build together and it is doing this... thing. And completely out of no where. NOTHING changed on my PC between the time I could play Watchdogs to when I couldn't 24 hours later. Can give anymore info if needed. Thank you for reading.
 
Last edited by a moderator:

ASK THE COMMUNITY