[SOLVED] Some games when i go into fullscreen lock to 15 fps while they work perfectly in windowed ?

niksonrex88

Commendable
Mar 4, 2018
61
0
1,630
0
First of all this isn't only in games, happens in VLC too. Also it doesn't happen in every game just a select few like: Hollow Knight, Genshin Impact and Minecraft Dungeons while some work perfectly like: RDR2, Hunt Showdown, FH4 etc.

Now what is super weird, i had this in more games and i was fixing it by clicking right click onto the desktop and clicking: Display settings>Advanced Display Settings>Display Adapter Properties, then i go to the monitor tab and change the hertz from 59 to 60 or vice versa. It didn't matter what it was on just that i change it. I could even change then revert and it would still fix the problem, id have 60fps in fullscreen games that didn't previously work.
But one day the option to change it disappeared!

Now it sits at 60 hertz and games that had the issue previously (R6S and LoL) don't have it anymore but the games that i still have the issue with still have locked 15fps in fullscreen.
No matter what i try, enable vsync, cap framerates... nothing fixes it.

I have the latest drivers for my GPU and i'm very dumbfounded at this. Games like Hollow Knight dont have a borderless fullscreen mode so i literally have to play them with the bar being visible on top since its a window.

If any of you have any idea what's causing this id gladly hear you out! Thanks in forward!
 
First off, if you're no longer getting the refresh rate options you were, there could be system file corruption. Therefore I recommend first doing a SFC scan.

Follow these instructions exactly.

https://support.microsoft.com/en-us/windows/using-system-file-checker-in-windows-10-365e0031-36b1-6031-f804-8fd86e0ef4ca

This of course assumes you are on W10, and if you are, you should also update it to at least 1909, because soon 1903 will not be supported with security updates anymore (Dec 8, 2020).

https://docs.microsoft.com/en-us/lifecycle/announcements/windows-10-1903-end-of-servicing

I highly recommend updating to the latest 20H2 build of W10, because it has a lot of fixes for 1909 in it, some of which were related to games crashing.

https://www.microsoft.com/en-us/software-download/windows10

Lastly, if you by chance still have the same problem, there are always various options to fix scaling and other problems in games on the Compatibility tab of the game's shortcut. Just right click the shortcut, and click properties, then compatibility.

In the compatibility tab under settings, you can try checking the box where it says Disable fullscreen optimizations. If that doesn't work, there's a tab at the bottom of that page (Change high DPI settings), which takes you to the next page that has options to fix scaling problems (Program DPI), or Override high DPI scaling behavior (High DPI scaling override).

These methods are commonly used, especially in games that do not have the best coding to be fully compatible with PC and/or Windows.
 
First off, if you're no longer getting the refresh rate options you were, there could be system file corruption. Therefore I recommend first doing a SFC scan.

Follow these instructions exactly.

https://support.microsoft.com/en-us/windows/using-system-file-checker-in-windows-10-365e0031-36b1-6031-f804-8fd86e0ef4ca

This of course assumes you are on W10, and if you are, you should also update it to at least 1909, because soon 1903 will not be supported with security updates anymore (Dec 8, 2020).

https://docs.microsoft.com/en-us/lifecycle/announcements/windows-10-1903-end-of-servicing

I highly recommend updating to the latest 20H2 build of W10, because it has a lot of fixes for 1909 in it, some of which were related to games crashing.

https://www.microsoft.com/en-us/software-download/windows10

Lastly, if you by chance still have the same problem, there are always various options to fix scaling and other problems in games on the Compatibility tab of the game's shortcut. Just right click the shortcut, and click properties, then compatibility.

In the compatibility tab under settings, you can try checking the box where it says Disable fullscreen optimizations. If that doesn't work, there's a tab at the bottom of that page (Change high DPI settings), which takes you to the next page that has options to fix scaling problems (Program DPI), or Override high DPI scaling behavior (High DPI scaling override).

These methods are commonly used, especially in games that do not have the best coding to be fully compatible with PC and/or Windows.
 

niksonrex88

Commendable
Mar 4, 2018
61
0
1,630
0
First off, if you're no longer getting the refresh rate options you were, there could be system file corruption. Therefore I recommend first doing a SFC scan.

Follow these instructions exactly.

https://support.microsoft.com/en-us/windows/using-system-file-checker-in-windows-10-365e0031-36b1-6031-f804-8fd86e0ef4ca

This of course assumes you are on W10, and if you are, you should also update it to at least 1909, because soon 1903 will not be supported with security updates anymore (Dec 8, 2020).

https://docs.microsoft.com/en-us/lifecycle/announcements/windows-10-1903-end-of-servicing

I highly recommend updating to the latest 20H2 build of W10, because it has a lot of fixes for 1909 in it, some of which were related to games crashing.

https://www.microsoft.com/en-us/software-download/windows10

Lastly, if you by chance still have the same problem, there are always various options to fix scaling and other problems in games on the Compatibility tab of the game's shortcut. Just right click the shortcut, and click properties, then compatibility.

In the compatibility tab under settings, you can try checking the box where it says Disable fullscreen optimizations. If that doesn't work, there's a tab at the bottom of that page (Change high DPI settings), which takes you to the next page that has options to fix scaling problems (Program DPI), or Override high DPI scaling behavior (High DPI scaling override).

These methods are commonly used, especially in games that do not have the best coding to be fully compatible with PC and/or Windows.
Alright, so i did the system checks and stuff. That didnt fix it but my "activate windows disappeared" after bugging out and appearing after i changed the date one day so thats great :D!

On the other hand turning off fullscreen optimization fixes it. Idk what this bug is it's super weird.

Thanks alot! Also i do have the 1909 ill think about updating it.

Just found out VLC still has the same bug but Hollow Knight doesn't. Im beyond confused.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS

Latest posts