Question Some question about my system and my RAM

Jul 10, 2021
5
0
10
0
Hello
This is my first post here
if you reading this thanks!

So I recently bought new RAM from crucial (4x4gb) but every stick was sent together but individually.
So when I Unpacked them I grounded myself and then replaced them with my old RAM. So when i plugged the power on it POST and then it started the screen black then beeped and turned off and then same thing happened but when I put the RAm in only 2,4 slots it works perfectly none ram is broken or anything they all work but maybe it's my DIMM slot is broken, and btw I am now with 12gb ram so 3 DIMM SLOTS work but the last doesn't or does it and when I play with 12gb more demanding games mostly I play WoW it just drops me a BSOD

My pc specs:
CPU:i5-4590 3.30ghz
GPU: GTX 1060 3gb
RAM: 4x4gb DDR3L 1600mhz UDIMM 1.35V
PC: Precision T1700
 
Last edited:

bccorrupt

Distinguished
Apr 18, 2012
992
16
19,665
200
Ram can be very picky about being seated correctly sometimes. Is there dust in the slots? Have you tried the ram 1 by 1 to verify each one works 100% for sure?

Is the slot that doesn't want to work one that you weren't using previously with your ram?
 
Jul 10, 2021
5
0
10
0
I tried to blow the slots I tried ram by ram but I know that 2 of them worked fine 1 just instantly beeped and the other one just showed something like that it doesn't find like my hdd or something but with other rams it worked perfect right now but not that beeping one
 

ASK THE COMMUNITY