Question Something is wrong with my PC

Sep 15, 2019
3
0
10
0
Before I explain my problem, here is my build

Motherboard: ASRock B85M Pro4 Micro ATX LGA1150

CPU: Intel Xeon E3-1231 V3 3.4 GHz Quad-Core Processor

Graphics Card: MSI GEFORCE GTX 960 2GD5T OC

RAM: G.Skill Ripjaws X Series 8 GB (2 x 4 GB) DDR3-1600

Storage 1: Samsung 250 GB 2.5" SSD

Storage 2: Seagate Barracuda 1 TB 3.5" 7200RPM HDD

Power: Corsair CX 430 W 80+ Bronze Certified Semi-modular ATX

OS: Windows 10, 64bit installed on SSD

My problem is that my PC has recently shown trouble opening programs, shutting down and starting up. For example, when i start PC after it has been set to sleep, programs take several minutes to open up. Further, shutting down takes just as long. I had to force shutdown my PC several times and yesterday, Windows had trouble to startup, going into repair mode. First thing I thought was something went wrong while installing recent updates. I reset Windows, while keeping my personal data. Then I ran check on my SSD, see if speeds have been compromised and checked the health - everything was OK.

Also, on startup before windows starts, I get a message from Asrock "Preparing Automatic Repair", which afterwards leads to "Windows had trouble starting up" - something along those lines. I checked BIOS, checked the boot settings. Seems like it boots from Windows Boot Manager. I set it to boot from SSD. Everything starts fine, except windows has still problem with tasks.

Hopefully someone can help with this issue.
 
Last edited by a moderator:

ASK THE COMMUNITY

TRENDING THREADS