Build Advice Something wrong about my build

Aug 16, 2020
2
0
10
0
Hello guys i hope someone help me, I built my first pc and the spec is: ryzen 7 3700x, rtx 2070 super, motherboard is msi X570 gaming plus, and when i turned on my pc everything worked for 2 minutes and suddenly everything went off, i thought there’s a problem on the way of building my pc, so I checked everything is plugged in correctly and when i tried there is some weird sound going out from the psu it’s like a switch or click , so i removed the motherboard from case and I unplugged everything and start from the beginning and i plugged everything correctly and when i tried the same problem happening ,nothing is working.. only the weird freaking sound, and i think my problem is from the psu, and i while i was checking my pc i saw something weird on the back of my motherboard it’s a weird white thing, it’s like burned, and also there’s some places next to the stand off screws it’s like been cracked i will post the pictures
 
Hello guys i hope someone help me, I built my first pc and the spec is: ryzen 7 3700x, rtx 2070 super, motherboard is msi X570 gaming plus, and when i turned on my pc everything worked for 2 minutes and suddenly everything went off, i thought there’s a problem on the way of building my pc, so I checked everything is plugged in correctly and when i tried there is some weird sound going out from the psu it’s like a switch or click , so i removed the motherboard from case and I unplugged everything and start from the beginning and i plugged everything correctly and when i tried the same problem happening ,nothing is working.. only the weird freaking sound, and i think my problem is from the psu, and i while i was checking my pc i saw something weird on the back of my motherboard it’s a weird white thing, it’s like burned, and also there’s some places next to the stand off screws it’s like been cracked i will post the pictures
What PSU do you have
 

ASK THE COMMUNITY

TRENDING THREADS