Question Sonic Studio III & ROG MAXIMUS X HERO : ASUS suppurt is ignoring my problem!!

Jan 30, 2019
7
0
10
0
Hi,
I've been using Sonic Studio III and it was working fine, but recently (last 3 or 4 months ) I noticed that most of my apps became so slow (like firefox, spotify, chrome ...) they hake ages to start. I found that NAHIMIC service is causing the issue.
So, I did contact ASUS support @ https://www.asus.com, then I got an answer from one of the team of advisors ASUS, He said that the product is made only to the following computers: GL12CS, GL504GM, GL504GS, GL704GM, GL704GW, GX531GM, which obviously doesn't make any sense, because it's advertised in their website that ROG X HERO does support SONIC STUDIO III, plus it was working and now all of a sudden is not supported? and I can't any official statement that says so, right?, so I told him that, again he denies without any further explanation?!!! then I said to myself maybe he is not aware of the issue, so I asked him to forward my question to developers or technical support because the app is packages with the audio driver from ASUS website Win10 x64 if he doesn't have much info -which is totally normal!!- I'm a developer at the end of the day and I can understand if it is a bug, in fact I wanna report bugs, that's what we do!! but guess what answer I got from him :
"We are delighted that the problem is resolved.
Thank you for choosing our service and I wish you a good day."

I can't see why he is delighted!! he didn't answer any question I asked him:

  • The app was working, and now it is not!!
  • Why the app is not supported anymore!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  • If, so why ASUS is still advertising that ROG X Hero supports it, is it a scam? I bought this MB for the premium features after all!!!!
  • If the app is not supported, why it is packaged with the audio driver!!!
Win10 x64
Version 6.0.1.8507
2018/09/28
from the date it is obviously that the driver is out of date, and if you do a little research you can clearly see that A LOT OF people facing the same issue which I told him btw!!

Conclusion: this situation is ridiculously stupid, I've always believed that ASUS has great hardware, I wish they put the same effort for their software and support as well!!

If you have a solution or clarification to the issue, please do not hesitate to help, thanks.
 

Similar threads


ASK THE COMMUNITY