Sons Rebuild Help

Jul 24, 2018
1
0
10
0
Rebuilding sons gaming comp.
new motherboard graphics cpu power supply. MOBO:MSI z370 gaming plus, Graphics: Evga 1050 , power evga 750 gq , core i5 cpu everything in correct powers up . No screen. Sorry first time mom trying to do this. Running old hard drive. Is there anything i need to install . Monitor showing no signal. HElp appreciated in the hole over this rebuild. Thank you greatfully
 

Ztdutxjgxgtu

Respectable
Nov 30, 2016
633
0
2,160
59
If you say rebuild , so your parts should have worked properly, no capability issue?
Then its youtube time to watch how people put together all the parts and troubleshoot.

When pc lights up, or fans spin, its a good sign
 
Go carefully through this check list (step by step):
http://www.tomshardware.co.uk/forum/261145-31-perform-steps-posting-post-boot-video-problems

One of most common errors would be plugging monitor into video output on motherboard instead of discrete graphics card video output.

BTW what cpu model are you using? z370 is compatible only with 8th gen Intel Core cpus - i5 8400(T), 8500(T), 8600(K)(T) ...
 

codygriffy

Honorable
Jan 4, 2013
284
0
10,860
43
Yes like he said if you're plugging your video cable into the mobo versus the graphics card you're gonna have problems. I know it's also simple, but check to make sure your CPU power cables are plugged in near the top of your mobo. They're VERY easy to miss / forget when installing new parts.
 
pull the gpu and one ram stick if it posts it may be a bios issue. on the msi mb check the bios rev sticker of the mb and look under the cpu listed parts for the mb from the vendor web page make sure your cpu is listed. it also list min bios needed to post it. make sure your mb has it. on the edge of the mb make sure the 8 pin eps cable is connected. on the mb make sure it not shorting to the mb tray that you used the brass standoffs to keep it from shorting out. check that the rear io shield not shorting the mb out.
 

ASK THE COMMUNITY

TRENDING THREADS