Sony Vaio blue screen on startup

KirkR

Distinguished
Nov 12, 2009
143
0
18,690
1
I don't know if this is the correct area to be posting, so if you know where I should post this, let me know, and I'll move it.

My friend had me fix his laptop for him, the laptop is a Sony Vaio PCG-384L. Here's what I've done so far.

-Try to replace Vista with Win7, fail. Won't boot from USB.
-Hook up laptop hard drive to my desktop, install Win7, success.
-Return laptop hard drive to laptop
-Start laptop

Here's my issue. When I start the laptop, it gets just past the "Starting Windows" Animation screen, and then I get a blue screen. The blue screen lasts about 10ms, so I can't get any codes. This is all I've been able to do for troubleshooting:

-Check to see if laptop hard drive boots in other computers : It does
-Check RAM
-Remove 1, test : fail
-Replace 1, remove 2, test : fail
-Put 1 in 2, vice verse : fail

Same issue each time, get past startup animation, blue screen.

I don't know how else to troubleshoot a laptop. I could seriously use some help.

Thanks in advance.
 

WR2

Polypheme
Hello kirkr;

-Hook up laptop hard drive to my desktop, install Win7, success.
-Return laptop hard drive to laptop

Is probably the root cause of your current problem. The Win7 install has drivers for your desktop PC and not the laptop.
If you have the Win7 installation DVD you should be able to 'repair' the problem to get the right drivers installed.
 

memadmax

Distinguished
Mar 25, 2011
2,492
0
19,960
95
heh.
You installed windows for *your* desktop.
So all the guts of windows is configured for your desktop, not the laptop.

So.... why did you take the hard drive out of the laptop in the first place?
Why didn't you stick the windows dvd in the laptops dvd player and boot off of that?
Are you using a unauthorized copy of windows?
 

KirkR

Distinguished
Nov 12, 2009
143
0
18,690
1


Well, when I try to install Win7 ON the laptop, whether I pick Setup or Recovery mode, after the Installation's "starting windows" animation, It shows the cursor on a black screen for about a second, then the laptop reboots.
 

KirkR

Distinguished
Nov 12, 2009
143
0
18,690
1


I'm using a USB copy I have, I'm currently not in possession of the disk itself.
 

memadmax

Distinguished
Mar 25, 2011
2,492
0
19,960
95
Ok, well, since we can't see what error message you are getting.
Put the hard drive in the laptop.
Hit F8 when it goes to startup and select "Enable bootlogging"
Let it run, and crash.
Take the hard drive back out, stick it in your desktop, but boot off the desktops' hard drive(different copy of windows)
Goto the laptops hard drive in my computer.
At its root(like D:\ or E:\ or whatever) look for the file named "ntbootlog.txt" and post that here.
 
Aug 25, 2019
1
0
10
0
Hello. My laptop is a Sony Vaio SVE141J running on Windows 8. After I press the start button, the logo shows on the screen for few seconds then blue screen all the way. I can see the cursor on the screen of blue and nothing else. I wonder if it has something to do with my laptop's RAM. It only has DDR3 2gb ram and only one slot has RAM. Will adding Ddr3 4gb ram to the vacant slot will do the trick? I need some advice how to fix it. Thank you.
 

ASK THE COMMUNITY