Question sound-card acting crazy ?

Jun 11, 2022
6
0
10
0
hello everyone :)

i have the asus xonar D2X for years now, sometimes in the past it showed a red cross in the task bar, but i managed by google to solve it everytime.

for the last two months now:

there are days, pc boots up with red cross on speaker icon, once after restart/reboot red cross is gone

there are days, theres no red cross, when first time booting up

there are days, i can restart/reboot the computer as many times as i want, the red cross is still there

in device manager no sound card is detected, even when show hidden devices

when downloading original drivers, during installation, the message, make sure theres extra power for the sound card before going on with installation, ( without ever having changed something at the hardware cables ), do you still want to continue installation, when yes, blue screen Disable the BIOS Cache or Shadowing follows, happens with all 3 original drivers for win 7 64 bit that exist

after failed installation of third time and blue screen crash restart/reboot, the speaker icon is there, with sound card detected

two days later, after booting up, red cross on speaker icon, no matter how many times i restart

i looked in BIOS, under advanced tab, doesnt have an option called cache or shadow

someone knows whats going on ?

thanks in advance
 
Jun 11, 2022
6
0
10
0
in disk management it seems to be legacy
in BIOS theres a line thats called ( usb device legacy support ) enabled

motherboard ( american megatrends inc. V5.3. 11.12.2009 )

couldnt find a line called CSM in boot menu of BIOS
 
okay thats a little bit better, bios doesnt show any shadow/cache option indeed
try disabling quick booting, maybe bios just needs more time to read your soundcard firmware properly, it should be under advanced bios features
 
Jun 11, 2022
6
0
10
0
after disabling, it takes the exact same time to boot up

but ... i tested by restarting and shutting down, each of those options, several times ... and the red cross on the speaker icon is still gone

may be its just a coincidence that your suggestion worked or not, i will let you know when the red cross comes back, thank you very much and so long, goodbye
 
Jun 11, 2022
6
0
10
0
today after booting up, red cross still gone, then i took a break, later when booting up again, red cross was back, after restart gone
 

ASK THE COMMUNITY