[SOLVED] Sound card drivers refuse to install

newspolygon

Prominent
Nov 21, 2017
4
0
510
0
A year or so ago I bought myself an ASUS Xonar DG sound card, because the integrated sound chip on my motherboard sucks. I plugged it in and installed the Win 7 drivers, and after some slight hitches I got it working.
Now I have upgraded to Windows 10. Upon downloading and launching the W10 drivers from ASUS I get an error message "ASUS Xonar DG audio does not exist, terminating now".
And that's it. I also tried using some open drivers; they failed to detect the card whatsoever.
Windows device manager sees the card as "Multimedia audio controller", and is not capable of finding the drivers for it.
I also tried Win7 drivers in compatibility mode, they failed to detect the card as well.
I read that the card may have an EEPROM issue, so I tried to fix it from a live FreeDOS USB, yet again the EEPROM software did not detect any card.
What do?
 
depending on the age of the windows iso that was used you may be missing motherboard chipset drivers. if the drivers are not installed then some pci devices may not work right. if your mb is intel mb download the newest intel chipset drivers. if it an amd ryzen go to amd web page and download the newest chipset drivers for your mb.
 

newspolygon

Prominent
Nov 21, 2017
4
0
510
0


I already tried those, they did not detect the card. I am now downloading mb drivers from the ASRock website, but there was no mention of a chipset driver so I am downloading an "AMD all-in-one driver"
 

newspolygon

Prominent
Nov 21, 2017
4
0
510
0


I just installed an "AMD all-in-one driver" from the ASRock website, because there wasn't one specifically referring the chipset, but nothing changed.
 

ASK THE COMMUNITY

TRENDING THREADS