Oct 1, 2019
Hi there,

So recently I updated my motherboard BIOS to try to fix another issue I was having with my monitors shutting off mid-game, and after I updated my BIOS my computer started running a chkdsk. Whenever I started windows up again I noticed that instead my motherboard was now booting to my HDD instead of my SSD, but whenever I went to switch to my SSD I noticed that it wasn't an option. I presume this may have been because whenever I installed Windows I basically just copied everything from my HDD to my SSD and now I essentially am running Windows over 2 hard drives. So I booted up with just my SSD plugged in and managed to change the setting to boot to my SSD first, then rebooted with my HDD installed. The problem comes in when now no audio works at all even though it was before the update, unless I use an external sound card that I have and still then I only get EITHER my audio OR my microphone to work. Unfortunately when I do try to plug in both my speakers and my headset I can run them both perfectly fine on another system (laptop).

Just some things that may help:

OS: Windows 10 Pro
Motherboard: MSI B450 Tomahawk ATX AM4 Motherboard
CPU: AMD Ryzen 5 3600 3.6 GHz 6-Core Processor
GPU: XFX Radeon RX 5700 8 GB Video Card
RAM: Corsair Vengeance LPX 16 GB (2 x 8 GB) DDR4-3000 Memory
PSU: EVGA 500 W 80+ Certified ATX Power Supply
My audio/mic are going in via 3.5mm aux, not USB via the rear panels

I have tried uninstalling 'sound, video, and game controllers' in my device manager, as well as 'audio inputs and outputs' and restarting my PC so that they update, still nothing.
I've checked to see if the 'RealTek HD audio' or whatever is enabled in the BIOS, which it is.
I've cleared the CMOS battery to try to go back to the original BIOS version.
I've tried 'disablind audio enhancements', which is all windows 10 troubleshooting has told me to do.
I've tried using a default driver by selecting 'let me pick from a list of device drivers on my computer'.
+ a few other things, I'd really like to try to fix this without having to reinstall windows and lose my programs. Let me know if there's something else I should try or anything else that you need from me to troubleshoot the issue, thanks.