Sound refuses to play on TV with HDMI....

CoqPwner

Honorable
Sep 4, 2013
5
0
10,520
1
As the title says, I am trying to set the default playback device to the TV, but the button Set Default is just greyed out for some reason and I can't find any solution online.
Any help on this one?
I can plug in Headphones or speakers in the audio jack and the sound comes out just fine, but I can't get it to come out from my TV apparently.

EDIT : I should add that the Playback Devices menu does detect my TV being plugged in as an audio device, it even says Ready. But the Set Default buttton is greyed out!
 

CoqPwner

Honorable
Sep 4, 2013
5
0
10,520
1


But my problem is that I CAN'T set it to default for some reason, the option is greyed out.
 

CoqPwner

Honorable
Sep 4, 2013
5
0
10,520
1
Problem resolved! I finally found the solution, I'll just copy/paste my post from another site :
Well! It finally works!
For the information of anyone who stumbles upon a similar problem. I ended up reinstalling the newest drivers of Realtek HD Audio via their website right here : http://www.realtek.com.tw/downloads...=24&Level=4&Conn=3&DownTypeID=3&GetDown=false

Next, to my great displeasure, NOTHING was working. The sound was just completely cut off, my speakers weren't working anymore, Itunes, Flash and any application using sound would actually crash upon startup and I was getting pretty mad. The sound was just saying my audio devices were disabled, even though they clearly weren't and Windows Troubleshooting said it couldn't do anything.

After some more research, I found this wonderful article : http://www.pcgamer.com/2011/11/10/t...dows-7-audio-problem-solved/audio-problems-5/

And did exactly as he said, running command prompt in admin, type :
net localgroup Administrators /add networkservice
net localgroup Administrators /add localservice
before restarting your computer.

And voila! Now the sound works fine through my headphones AND through my TV!

The downside though, as explained in the article, is that this lowers the security of your computer, basically giving admin access to programs. To avoid this, he suggests simply resetting your Computer to factory settings, but since I actually had the problem with factory settings, I doubt that would help.

So anyway, issue resolved, thank you for your help.

EDIT : Oh, well good news! I was a bit worried about leaving these administrators rights like this so after re-starting my computer and making sure the sound still worked. I typed the reverse commands:
net localgroup Administrators /delete networkservice
net localgroup Administrators /delete localservice

Hence removing what I had just done. I restarted again and the sound still works fine. Try this if you are worried about the security problem.
 

ASK THE COMMUNITY

TRENDING THREADS