Question Soundblaster Audigy Fx Driver Problem

Jul 16, 2019
6
1
15
0
When i start the win10 first in the morning my sound card has wrong driver (high definition audio device). After a restart works fine (Soundblaster Audigy Fx). The High Definition Audio driver has only rear speakers (i have a Logitech X-530 5.1 speaker system). every time i want to use my computer i have to start and restart. Could you tell me a solution for this problem?
i have this system:
Ryzen 5 2600
Kingstone Hyperx 8 GB 2400 Mhz X2
Msi 1660 ti armor
Windows 10 pro 64bit
Gigabyte b450 Aorus m
Samsung Evo 970
Soundblaster Play3
Soundblaste Audigy Fx
https://kepkuldes.com/images/0d95ad8fd1a07895d587087554fc6cb9.png
https://kepkuldes.com/images/1b44984faba8229512d0898ece67f8f8.png
 
Last edited:

Colif

Titan
Moderator
see if this helps

right click start
choose power options
on next screen, under Related Settings, click Additional power settings
on next pop up, on left, click "Choose what the power button does"
on next screen, next to the blue/yellow shield, click :Change settings that are currently unavailable"
untick the box next to "Turn on fast startup"
click save changes

what is likely to be happening is the audigy drivers don't like the new power modes in win 10 and don't work on a fresh start until you do a restart. Turning fast startup off means PC is actually off when you shut it down. With it on, the PC is in a hybrid hibernate which can cause older drivers to bug out.
 
Jul 16, 2019
6
1
15
0
see if this helps

right click start
choose power options
on next screen, under Related Settings, click Additional power settings
on next pop up, on left, click "Choose what the power button does"
on next screen, next to the blue/yellow shield, click :Change settings that are currently unavailable"
untick the box next to "Turn on fast startup"
click save changes

what is likely to be happening is the audigy drivers don't like the new power modes in win 10 and don't work on a fresh start until you do a restart. Turning fast startup off means PC is actually off when you shut it down. With it on, the PC is in a hybrid hibernate which can cause older drivers to bug out.
Thank you for helping me but it didn't work. Maybe if the problem is in the fast setup i can't solve it because my windows 10 was installed to UEFI bios. I'm not an IT just know that this case the bios load the driver before the win10. Maybe this is the root of the problem. I tryed to turn off the fast boot at the bios but also didn't work. I won't reinstall my windows so i 'll live with that :).
Thank you for your help again!
 
Last edited:

Colif

Titan
Moderator
Fast boot in windows is not the same thing as fast boot in bios, they do 2 different things

Fast boot in bios just speeds up how fast PC loads by turning off features in BIOS, it doesn't load any drivers that windows uses. Can be 2 types of fast boot in bios.. fast boot which disables any extra USB devices apart from mouse/keyboard at boot, and Ultra fast boot that does that and other steps to make boot up really fast. With an ssd, you shouldn't really need either.

Meanwhile, Before Win 10 was released, when you turned a PC off it was off. Which makes sense... but Win 10 doesn't turn off when shut down, it goes into a hybrid hibernate mode which many older drivers aren't written to cope with.

So turning fast startup off (the windows version) doesn't change the behaviour? That is odd, the PC shouldn't swap drivers like that, should stick to one driver. restarting PC shouldn't make any difference. with it off, turning off and restarts are the same thing?
 
Jul 16, 2019
6
1
15
0
Fast boot in windows is not the same thing as fast boot in bios, they do 2 different things

Fast boot in bios just speeds up how fast PC loads by turning off features in BIOS, it doesn't load any drivers that windows uses. Can be 2 types of fast boot in bios.. fast boot which disables any extra USB devices apart from mouse/keyboard at boot, and Ultra fast boot that does that and other steps to make boot up really fast. With an ssd, you shouldn't really need either.

Meanwhile, Before Win 10 was released, when you turned a PC off it was off. Which makes sense... but Win 10 doesn't turn off when shut down, it goes into a hybrid hibernate mode which many older drivers aren't written to cope with.

So turning fast startup off (the windows version) doesn't change the behaviour? That is odd, the PC shouldn't swap drivers like that, should stick to one driver. restarting PC shouldn't make any difference. with it off, turning off and restarts are the same thing?
I turned off both fast boot (win10 and bios). Unfortunately my PC did same. First turn on i have High Definition Device after that with every restart my sound card works fine. I have another idea. I have connected to my computer an LG samrt tv via HDMI cabel (video and audio). The Nvidia uses High Definition Driver (i think) for that. Maybe could it be the problem?
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS