Question Soundcard issues - flickering screen

Jun 28, 2021
12
0
10
0
Hello,
I was using my SoundblasterX G6, when suddenly all the noise was distorted, I unplugged the USB cable and plugged it back in and it worked fine. A few days later it happened again, but replugging the cable didn't work this time.
Things I have tried for this issue:
- Use a different USB Cable -> still persists but is less common
-Uninstall Audio Drivers using DDU
-Uninstall GPU Drivers with DDU
None of these have seemed to help. The weirdest thing of them all is this problem that happened when the USB cable MADE contact with the soundcard, even though the cable was the wrong way around:
View: https://youtu.be/dtOK1hm8IRs

As seen in the video, my monitors would completely flicker and glitch out when there was contact made with the USB cable and the soundcard, but it wasn't even plugged in. I am SO confused why this is occurring.
If you have any advice I would appreciate it highly. I am using the soundblaster with Creative Speakers and a Beyerdynamic DT990.
Specs:
R9 5950X
RTX 3080TI
 

Lutfij

Titan
Moderator
When posting a thread of troubleshooting nature, it's customary to include your full system's specs. Please list them like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS: include OS version(not edition) if Windows 10
Monitor:

Please parse any USB hubs that you may be using in tandem with the soundcard. I'm assuming you have hubs or long cable runs seeing how it's managed under your desk. Include BIOS version for your motherboard and the age of the PSU(apart from it's make and model + wattage).

If the blackout happens when you merely contact the USB port without plugging it into completely, then you might be suffering a grounding issue.
 
usb and monitors have in common 5V rail from PSU...but u say usb cable was not connected to pc, right?
usb itself can do some emi and monitor cable if not properly shielded can pickup such things
in this case move usb cable away from monitor cables
 
Jun 28, 2021
12
0
10
0
When posting a thread of troubleshooting nature, it's customary to include your full system's specs. Please list them like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS: include OS version(not edition) if Windows 10
Monitor:

Please parse any USB hubs that you may be using in tandem with the soundcard. I'm assuming you have hubs or long cable runs seeing how it's managed under your desk. Include BIOS version for your motherboard and the age of the PSU(apart from it's make and model + wattage).

If the blackout happens when you merely contact the USB port without plugging it into completely, then you might be suffering a grounding issue.

CPU: Ryzen 9 5950x
Mobo: Aorus Gigabyte X570 Master - F33 Bios Version
RAM: TridentZ Gskill RGB 4000mhz
SSD: Samsung 980 m.2
GPU: 3080 TI FE
PSU: Corsair RM1000X (1000watts) - 3-4 months old (all parts are this old, newly built pc)
Chassis: Lian Li O11 Dynamic
OS: Win 10 21H1
Monitor: x1 Zowie XL2546k - x2 Zowie XL2411Z
 
Jun 28, 2021
12
0
10
0
usb and monitors have in common 5V rail from PSU...but u say usb cable was not connected to pc, right?
usb itself can do some emi and monitor cable if not properly shielded can pickup such things
in this case move usb cable away from monitor cables
The graphical problem isn't persistant, I just wanted to know if this is something i should act upon or just leave it, i mean it didn't look healthy to me but shrug
 

ASK THE COMMUNITY