Speaker problems!

G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.hardware (More info?)

I don't know what happened. My speakers are hooked on the back, nothing seems
out of place but when I press the POWER button, nothing happens. It simply
doesn't turn on ( the little green light is out! ). I don't know what to do!
Can somebody please help me? I'm getting desperate.

PS. I have a Windowns XP Home Edition ( Compaq ) and my speakers are FLC
Presario Speaker System.
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Hello

Pretty simple make sure it's plugged in and if you check that
and still no power toyour speakers, check your outlet, if all
that checks out and your outlet is fine and working go out
and purchase some new speakers.

Alvin


needhelp27 wrote:

> I don't know what happened. My speakers are hooked on the back, nothing seems
> out of place but when I press the POWER button, nothing happens. It simply
> doesn't turn on ( the little green light is out! ). I don't know what to do!
> Can somebody please help me? I'm getting desperate.
>
> PS. I have a Windowns XP Home Edition ( Compaq ) and my speakers are FLC
> Presario Speaker System.
 

papa

Distinguished
Apr 6, 2004
512
0
18,980
Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Did you plug in the speaker power supply?

"needhelp27" <needhelp27@discussions.microsoft.com> wrote in message
news:610A236F-ADED-439E-A3B3-9DE1C8E1D2D2@microsoft.com...
>I don't know what happened. My speakers are hooked on the back, nothing
>seems
> out of place but when I press the POWER button, nothing happens. It simply
> doesn't turn on ( the little green light is out! ). I don't know what to
> do!
> Can somebody please help me? I'm getting desperate.
>
> PS. I have a Windowns XP Home Edition ( Compaq ) and my speakers are FLC
> Presario Speaker System.