Question Speed test is significantly faster on my phone than on my ethernet desktop. What could be the reason?


May 5, 2018
I'm currently running the following setup:

Router: ASUS RT-AC68U
Motherboard: ASUS ROG Maximus X Hero
Ethernet Cable: Various cables, tried many

I'm paying for 200mbps from Spectrum in Moscow, ID, and I've always been confused why my internet is so much slower than that. On my desktop, compared to mobile, I have very different speeds.

Google Speed Test: 21.5 mbps down
Speedtest by Ookla: 168.26 mbps down
Speed Of Me: 11.54

Google Speed Test: 196.8 mbps down
Speedtest by Ookla: 224.49 mbps down
Speed Of Me: 11.47

In the past, to remedy this, I tried updating my ethernet drivers directly from the ASUS site. The installs never worked, not the setup.exe file that is provided, nor the asussetup.exe file that was provided. I once got in contact with a customer service agent who provided me with alternative files which fully broke my ethernet capabilities, after which he quickly peaced out and I had to reinstall my whole damn operating system just to have internet again. Fun times!

I was wondering if anyone on this forum had a better solution. It makes sense to me that Speed Of Me is the same for both devices. But why is Google's speed test, Speedtest by Ookla, and just general day to day usage off by nearly 150mbps?
Asus bundles some crap "gamer" network QoS/accelerator software. This has a history of massive issues and has a lot of overhead on a fast internet connection. If you have any of this software I would uninstall it.

It depends on what you have for end devices. A very simple test program is called iperf. You should see 900mbps between 2 ethernet connected machines. This will validate your cable, driver etc. It only tests the network itself though. You could also try to copy large files between your machines and watch the speeds in resource manager....note some of those are in MBYTE not mbits so read carefully.

You can also try to boot a linux USB image. You can run speedtest on this and it would quickly see if it was a hardware issue with your machine or it was something in windows causing it.
Reactions: Mandark
Jun 20, 2021
Based on your statement, we can tell the following facts:
  1. ASUS ROG Maximus X Hero has 1000mbps enthernet card, unless this motherboard has been sent to some repair shop and the original enthernet chip has been ripped off.
  2. ASUS RT-AC68U is capable of routing 1000mbps network.
The problems maybe:
1. The cable, you seem be very aware of the equipments you are using now, but mentioned little about the cable, try to search the term"CAT5", "CAT5E" and "CAT6"... on the internet and check that whther the cables you use match the specifications needed.
Reactions: Mandark