Question Speedtest.net shows slow download speed but task manager shows otherwise

Apr 12, 2020
2
0
10
0
Got a new isp which worked fine for more than 3 months but on the 9th day of lockdown, the speed reduced to 1/10th. I blacklisted all of the other users but the speed remained slow. I then contacted the service provider and was advised to play a 4k video on Youtube and keep an eye on the wifi speed consumption but the speed, this time the speed was good. The problem arises when the browsing suddenly slows down on various sites and most of the videos at various sites, no matter how low the resolution must be, takes a lot of time to buffer or download.
I have tried restarting the router and changed the channel but the speed remained slow. I have a 2.4ghz router. I have also tried the speedtest on another device but showed the same speed.
 
You need to try a bunch of speedtest sites and see if they are different. It could be interconnection between ISP. There might be some issue to one or more ISP where other ISP are fine.
I would also try a number of web browser just in case it is something with the software itself.

You should really test on ethernet to really be sure it is not the wifi. Generally all sites will work like poorly when it is the wifi causing the problem. it is not like there is another path your traffic can between your machine and the router that is better for some sites.

Maybe something like pathping will show you something interesting. Don't read a lot into it though it is just 1 tool and you must confirm things with other tools.
 
Reactions: Luqman Qureshi
Apr 12, 2020
2
0
10
0
You need to try a bunch of speedtest sites and see if they are different. It could be interconnection between ISP. There might be some issue to one or more ISP where other ISP are fine.
I would also try a number of web browser just in case it is something with the software itself.

You should really test on ethernet to really be sure it is not the wifi. Generally all sites will work like poorly when it is the wifi causing the problem. it is not like there is another path your traffic can between your machine and the router that is better for some sites.

Maybe something like pathping will show you something interesting. Don't read a lot into it though it is just 1 tool and you must confirm things with other tools.
I have tried speedtest, fast and testmy.net and all of them show approximately 1 to 5 Mbps when my connection is of 10mbps. I used to get 10mbps until 2 weeks ago.
I have tried chrome, firefox, internet explorer and edge but all of them show the same results
I tried to check the speed after placing my phone on the router but the speed stood the same. Though I will check the speed using ethernet if I could access the cable considering the lockdown.
could you post a link to a pathway software?
 

ASK THE COMMUNITY

TRENDING THREADS