Question [Spooky PC issue] PC requires multiple restarts to finally boot BIOs/OS

Mar 26, 2020
2
0
10
0
Hi all,

I am having a weird issue with my PC that I cannot find anyone else asking about or find a solution.

My PC requires multiple hard restarts to get it to boot the initial intel screen. From there, I have to select my SSD in order to boot my OS (pressing f10 -> selecting SSD).

When my PC turns on and does not boot the initial intel screen, the fans run at high speeds and the lights come on, but no actual program boots. When the comptuer does actually boot properly, the fans reduce in speed and I get power to my mouse (i.e., the RGB lights come on my mouse). Once the computer is actually on and working, it does not shut off.

Any ideas of the issue? could it just be a power supply issue or motherboard issue?

Appreciate any ideas :)

Specs:

OS: Windows 10 home 64-bit (10.0, BUild 18362)
Processor: Intel Core i7-2600k @3.40GHz (8 CPUs), ~3.4GHz
Memory: 8192MB Corsair RAM
Graphics: NVIDIA GeForce GTC 670
Motherboard: Intel DZ77SL-50K
BIOS Version/Date: SLZ7710H.86A.0081.2012.0719.1051, 7/19/2012
Power Supply: ZT series 750W

Thanks!

edit: Not a new PC - have had this PC for quite awhile and only had this problem recently.
 
Last edited:
Mar 26, 2020
2
0
10
0
p.s. I took my computer into the shop to be troubleshooted - the tech said that it was likely my motherboard. They replaced my RAM, CPU, and graphics, and it was consistently giving error messages.
 

ASK THE COMMUNITY

TRENDING THREADS