SSD bad sectors?

comanderBARNIK

Honorable
Aug 6, 2012
37
0
10,530
0
Hey all I just recently bought my vertex 450 256 gb whisI formated for instalation of win 7. It worked insanely good about a month then suddendly I got long boot time, prompt to check disk for data integrity. chkdsk wrecked my os completely, changing some atributes, fixing registry. nothing worked afterwards and there was no icons nor image previewing. All update history was erased and system backup has been corupted.

I quick formated it (on win7 installer), set up win again, but before I even installed SP1 it checked again for disk integrity and the whole store repeated itself. Had also BSOD during boot 2 times which disappeared after system repair. update history and os backup gone as well again.

Should I return ssd on warranty to the shop or is it just me not formating it properly? Could it be a virus?

I'll be very grateful for any advice on this.
 

RealBeast

Titan
Moderator
If you check its SMART values and they are okay, do a secure erase and then reinstall your OS.

And don't waste your time running CHKDSK on your SSD, it doesn't do anything for an SSD and its results are not meaningful. You had some data corruption, virus, or whatever.
 

comanderBARNIK

Honorable
Aug 6, 2012
37
0
10,530
0
Oh and about the first part - why would it die after one month and not instantly?if I formated it wrong at the beginning shuldnt I get this chkdsk mess immediately? Could it be some sor of virus that might caused it?
 

RealBeast

Titan
Moderator
Run SMART tests on it to find out if it is working and just needs a secure erase, not worthwhile to waste time speculating about if and why since you can test it.

It could be a virus or other corruption, difficult to know.
 

Akashdeep

Distinguished
Feb 9, 2011
938
0
19,160
88


Your SSD is physically OK.

You might have some virus or malwares through your some of applications or games. Do a proper virus scan. Also check for malwares with "Malwarebyte AntiMalware".
 

lonewolf7

Splendid
Moderator


The pic's suggest that everything is fine. Nothing to worry about. Try to clean install OS again. And check your RAM with memtest.

 

comanderBARNIK

Honorable
Aug 6, 2012
37
0
10,530
0
Okay so I was hesitant to do everything as I had some work do get done and chkdsk no longer wrecked my os, but finally secure erased it with parted magic, set up part table GPT (had msdos chosen by deafult, not really sure what are these and what do they do).

Everything works perfectly fine , not even a slightest error :) thank you guys
 

Similar threads


ASK THE COMMUNITY

Latest posts