[SOLVED] SSD doesn't show up on boot options in config, only when I press F12, also frequent BIOS corruption

BaronSamedi

Reputable
Jun 28, 2017
16
0
4,520
1
My system is as follows
  • Windows 7 Ultimate
  • 44gb, 28gb DDX3
  • Coolermaster hyper 12 Evo Fan.
  • 2 graphics cards, a GT440 and a GTX 1070 I recently upgraded to do machine learning/neural network stuff on.
  • Various hard drives and one system SSD
  • Corsair CX 750N
I now find that my system won't boot from the SSD unless I press F12, from where I can manually select it. If I go into the BIOS config and try to select the SSD it doesn't show up on the list of options, but it does show up when I press F12.

I also get, less frequently but still far too often, the system crashing with a blue screen of death, and on reboot the BIOS is corrupted and needs to be copied from backup.

I'd be super grateful for ideas in troubleshooting/diagnosing root cause for these two issues as at present all I can really think of is randomly replacing parts from the cheapest upwards.
 

BaronSamedi

Reputable
Jun 28, 2017
16
0
4,520
1
Thanks for the reply again.

I managed to fix the issue.

What had happened was that the bios got corrupted and re-flashed a couple of times. This reset the settings. During this process it looks like the available drives to boot from were set to default values. I dug around the config and found there were some settings which set up the available drives for booting on another screen, separate to the boot order (which is what I'd been struggling with).

Thank you for reading and sorry to waste folks time. How do I mark the thread as resolved?
 
My system is as follows
  • Windows 7 Ultimate
  • 44gb, 28gb DDX3
  • Coolermaster hyper 12 Evo Fan.
  • 2 graphics cards, a GT440 and a GTX 1070 I recently upgraded to do machine learning/neural network stuff on.
  • Various hard drives and one system SSD
  • Corsair CX 750N
I now find that my system won't boot from the SSD unless I press F12, from where I can manually select it. If I go into the BIOS config and try to select the SSD it doesn't show up on the list of options, but it does show up when I press F12.

I also get, less frequently but still far too often, the system crashing with a blue screen of death, and on reboot the BIOS is corrupted and needs to be copied from backup.

I'd be super grateful for ideas in troubleshooting/diagnosing root cause for these two issues as at present all I can really think of is randomly replacing parts from the cheapest upwards.
full specs?
 

BaronSamedi

Reputable
Jun 28, 2017
16
0
4,520
1
Thanks! Full spec (hopefully) as follows...


CPU: AMD FX 8350 Black Edition 4.00 GHz 8 MB 125 W Octa Core Processor with coolermaster hyper 12 evo fan
Motherboard: Gigabyte 970A-DS3P AMD 970
Ram: 4 x 4GB ddr + 2 x 8gb DDR (total 32gb)
Main SSD: Sandisk Ultra 2 SSD
Hark disk: Western Digital Caviar WD1600 HDD
Hark disk:
WD10EZEX Sata HDD 1TB
Hark disk: WD20EZRX 2TB HDD sata
GPU: Gigabyte Nvidia GTX 1070 G1 8GB GDDR5 PCI-E graphics card
PSU: Corsair CX CS 650M PSU (Green label)
Chassis: Novatech tower chassis, pretty old, don't have the model number
Operating system: Windows 7 ultimate 64 bit
Monitor1: LG 23MP68VQ 23-Inch
Monitor 2: LG W2261VP 22 inch
 

BaronSamedi

Reputable
Jun 28, 2017
16
0
4,520
1
Thanks for the reply again.

I managed to fix the issue.

What had happened was that the bios got corrupted and re-flashed a couple of times. This reset the settings. During this process it looks like the available drives to boot from were set to default values. I dug around the config and found there were some settings which set up the available drives for booting on another screen, separate to the boot order (which is what I'd been struggling with).

Thank you for reading and sorry to waste folks time. How do I mark the thread as resolved?
 

ASK THE COMMUNITY

TRENDING THREADS