Question ssd freezing up heavily

Sep 22, 2019
2
0
10
0
I have recently bought a xpg sx6000 pro 256gb M.2 ssd for my laptop, I installed a fresh version of Windows 10 but after a couple of minutes it starts freezing up, heavily. I didn't have that problem on my 1tb hdd that I had before. I checked the Lenovo site to see if the ssd was compatible and it was. Any kind of advice would be much appreciated!!

My pc:
Lenovo Legion y520
i5-7300hq
16gb ddr4 2166mhz ram
gtx1050 4gb
1tb Toshiba hdd
256gb xpg6000 Pro m.2 ssd
 

Ralston18

Titan
Moderator
Use those couple of minutes to open Task Manager and find out what all is running - laptop could be trying to download and install updates. Check the Startup tab to ensure that some unwanted app has not been added.

But do not delete anything without some additional research as to what it is and why it may be running.

You can also use Resource Monitor to observe system performance.

And Reliability History may provide some error codes and warnings relevant to the freeze ups.
 
You installed fresh windows on the SSD, but, does the old hard drive still contain the old installation as well? And your applications?

That can cause 'confusion'...the new OS on the SSD would have no idea where anything is located, the applications would need to be reinstalled for a fresh Windows install...(vice just steering to the old shortcuts, or whatever was being done?)

Disconnect the old drive, and see if the SSD in question runs ok by itself...
 
Last edited:
Sep 22, 2019
2
0
10
0
You installed fresh windows on the SSD, but, does the old hard drive still contain the old installation as well? And your applications?

That can cause 'confusion'...the new OS on the SSD would have no idea where anything is located, the applications would need to be reinstalled for a fresh Windows install...(vice just steering to the old shortcuts, or whatever was being done?)

Disconnect the old drive, and see if the SSD in question runs ok by itself...
I formated the hdd during the installation of windows. and i did try to run it with just the ssd, it still lagged.
 

ASK THE COMMUNITY

TRENDING THREADS