Question SSD Fried?

Mar 31, 2019
3
0
10
0
I built my computer with a 500GB Samsung Evo SSD from the start, always worked with no issues. Today I bought a new 1TB WD Blue for additional storage, and after plugging in SATA and power, I booted my computer up to receive the "Reboot and Select Proper Boot Device" message. I did have Windows 10 on my SSD. It seemed BiOS was detecting the WD HDD but it was not detecting the SSD. I'm not sure what I could have even done to fry the SSD, it was a simple 2 cord install in my case. Any help is appreciated.
 
Are you going onto boot load or actually changing the default BIOS boot sequence?
Have you checked to see if the SSD is enabled in the BIOS?
Do you have latest BIOS installed?
Have you then tried a different SATA cable / then port?
 
Mar 31, 2019
3
0
10
0
I already tried using another SATA port, which was unsuccessful. I also removed the new WD HDD and tried to start up normally as if I never introduced the new parts to begin with, and that just brought me straight to BIOS. I'm using the same SATA cable that I started with that never had issues. I changed both the boot sequence and manually choosing a drive to boot from, but only the WD shows up as an option.
 
can't imagine why your Samsung would disappear over a simple addition of another storage drive...if ti no longer shows up in BIOS, on any port, with any known good SATA data cable and power is known good...it is likely 'done'. (Some people have mixed success by connecting power to it while system is alive and on, but, I'm not comfortable with it, personally)

Did you introduce an unknown SATA modular power cable into the mix, or, was the SATA power cable already there from current PSU? (Many folks bring SATA power cables from older PSU or a secondary build, plug them into a different PSU without worrying about pinout at PSU, and then quickly fry SSDs, drives, etc..)
 

Karadjgne

Titan
Herald
Try this.
Unplug pc.
Unplug both drives.
Pull the battery, hold down the power button and count to 30. Slowly. Replace battery.
Plug in power and boot up. It'll take you to bios and a screen will tell you hardware has changed etc etc. F10 to save and exit. Shutdown.
Plug in SSD into Sata 0/1 ports.
Plug in WD into Sata 3/4 ports.
Boot. Both drives should be recognized. Bios will rewrite itself with the new hardware info, so F10 to save and exit again.

There's a phenomenon where Sata has a hole in its thinking and the handoff between Port 0 and Port 1 gets fuzzy and can sometimes switch temporarily, leading to a drive not recognized. Usually uefi bios gets around this by boot order looking for specific drive, not specific port address. If you switch the drive to non-uefi boot order, you can get the wrong port and the drive shows up as non-existing.

Reset bios usually works.
 

ASK THE COMMUNITY

TRENDING THREADS