[SOLVED] SSD Gone bad: Can recover data but can't format/erase?

Nov 29, 2019
1
0
10
0
Hi, I'm running an asus x399 aourus pro windows 10 (multiple versions), and I've had a WD blue M.2 500GB SSD go RAW on me - at the time it was by boot drive.

I've made a fresh OS install and used EaseUS to recover the data from the failed drive - that is to say my mobo is clearly able to access the data on the disk and recover it.

Here's the part that's got me scratching my head: I'm getting I/O device errors from it. when I went to format the drive disk manager simply showed the partition status as "formatting", even after leaving it for a full 24 hours... then going into diskpart and running "clean" gives me an I/O device error.

Does anyone know what's going on here? Surely if I can read the entire contents of the drive and copy them elsewhere I should be able to format the thing, right? ... right? I must be missing something obvious.

A few extra details: I'm pretty sure I messed it up in the first place by filling the drive up pretty much completely - I know, I got careless. Whenever I connect the drive to my system it slows the whole thing down and accessing anything on the drive takes between 20 minutes and two hours. I've also tried moving the drive to a different M.2 slot on my MOBO: no dice, same behaviour.
 

ASK THE COMMUNITY

TRENDING THREADS