Question SSD I/O Error, can't format disk

Jun 18, 2019
3
1
10
0
hello guys,
I have bought an M.2 Nvme SSD 240G Kingston , I've Installed windows 10 on it, after Windows update is done, laptop rebooted and didn't boot windows and laptop is not detecting windows anymore (not in EFI list)

. After that I have successfully booted to Windows by using grub uefi boot -I thought that problem is solved- but after that each time I boot to Windows all files ( data) that Ive made during that session is deleted so basically windows is not saving new data

.So as a last step; I tried to format/wipe every thing in that NVMe, using linux (fdisk+gparted) but all failed (I/O Errors) even command (dd if=/dev/zero of=/dev/nvme0n1p1) don't make any changes to partition nvme0n1p1.
-also tried using windows disk to format nothing changed-
and that's the log for smartctl -x nvme0n1p1
https://pastebin.com/7b7rBr2y

So, does that mean SSD is broken? or it's software problems?
thanks in advance.

ssd : kingston A1000 240GB
device : laptop

the whole ssd partitioned into 4 partitions for 1 windows os so I'm unable to install any other os on it
 
Reactions: paulo.villani
Aug 22, 2019
1
0
10
0
I am facing EXACTLY the same problem with an M.2 Nvme SSD 240GB Kingston drive (A1000).
I cant boot normally, but after restart all the change I've made on disk were reversed.
I've tested the device with Kingston SSD manager version 1.1.2.1 software, but no errors was found (also, after reboot the software installed was vannished from the drive).

Other test I did was mount the drive in linux and tried to create and erase files. No errors was reported on doing that, but after press f5 (or another ls on terminal) the files created was gone and files erased was back.
I have no idea what in going on.

Kingstone SSD Manager - Version 1.1.2.1 output:
https://pastebin.com/7KZsyyBQ

Momani, did you found any solutions ?
 

ASK THE COMMUNITY

TRENDING THREADS