Question SSD is showing but no HDD

Jan 15, 2021
5
0
10
0
I'm new here!
So, I have an SSD on my computer and a bought a new HDD, it's a WD RED 2TB, I've tried to install but is not showing up on device manager, tried to use the same SATA cables from my SSD to my HDD and still not showing on device manager, any tips or anything I can do to solve this?
I'm running on a windows 10.

edit. I was trying to listen the HDD and it doesn't sounds like it's running.
Thank you guys!
 
Jan 15, 2021
5
0
10
0
No, is not showing in the bios or disk management.
Fun fact: Tried to use the same sata cables from my SSD that works fine and the HDD doesn't appear.
Guess they send me a broken one, for the second time.
 
No, is not showing in the bios or disk management.
Fun fact: Tried to use the same sata cables from my SSD that works fine and the HDD doesn't appear.
Guess they send me a broken one, for the second time.
You could try booting with only the new HDD connected, in place of your SSD, to see if it shows up in the BIOS. Connect it to the same SATA port as you were using for the SSD.
 
Jan 15, 2021
5
0
10
0
You could try booting with only the new HDD connected, in place of your SSD, to see if it shows up in the BIOS. Connect it to the same SATA port as you were using for the SSD.
I already tried this, just removed my ssd and used the cables from the ssd into the new HDD and still the same, isn't showing in the bios or disk management.

almost sure that it's a problem with the HDD. I just can't believe because this is the second one that i bought and doesn't work.
 

ASK THE COMMUNITY