[SOLVED] SSD m.2 and hard drivw wont read at the same time

Dec 25, 2019
5
1
15
0
I recently got a 1GB m.2 but when I put it in either my hard drive or ssd wont show up. For some reason I can only see either my ssd and m.2 or my ssd and hard drive however I can never see all 3. Ssd is my boot drive right now.
 
Jul 14, 2019
85
10
45
4
Here's a quote from the specs of your mobo

"*M2_2 and SATA3_3 share lanes. If either one of them is in use, the other one will be disabled."

Is either drive using a conflicting port? If you are unsure, check your documentation that came with your motherboard or check the PDF online and see if this is possibly the issue.
 
Reactions: Halozeus
Jul 14, 2019
85
10
45
4
I assume you mean 1TB m.2? anyhow...
Are you saying that your visible drives in windows change based off of what drive you boot from, or they change as you reboot without changing anything, or what? Also, please post your system specs.
 
Dec 25, 2019
5
1
15
0
System specs:
Ryzen 5 3600
Gtx 2080
32gb ddr4 3200
Steel legend b450 micro atx mobo
Also 750w modular psu from evga
I am saying that after plugging in the new m.2 the hard drive no longer shows up but when I take out the m.2 it shows back up. I am not unplugging anything from the hhd and I am booting from a 240gb ssd used specifically as a boot drive. Also checked bios and it doesnt show up there either.
 
Jul 14, 2019
85
10
45
4
Here's a quote from the specs of your mobo

"*M2_2 and SATA3_3 share lanes. If either one of them is in use, the other one will be disabled."

Is either drive using a conflicting port? If you are unsure, check your documentation that came with your motherboard or check the PDF online and see if this is possibly the issue.
 
Reactions: Halozeus
Dec 25, 2019
5
1
15
0
Now I feel dumb because I remember reading that when buying my m.2 and saying "I wont make that mistake" thank you it works now 😂
 

ASK THE COMMUNITY

TRENDING THREADS