• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question SSD M2 not recognized after graphics card change

Apr 19, 2020
1
0
10
0
Hi all,

I am having a very strange problem with my SSD M2. After I have changed my graphics card from MSI GTX 950 OC to Asus Strix RX580 8GB my SSD M2 is not recognized anymore by the PC. The HDD is fine all the time.


I found a strange fix which is:
  • remove RX580 (new one)
  • boot PC without monitor
Computer boots - m2 found.

Then I:
  • add RX580
Computer BOOTS AGAIN! Everything works fine. But after 2-3 weeks, the m2 is not found again, even when the PC is on (idle). :(
The SSD is mounted BELOW the graphics card. I also mounted it above but no luck.

This is the only change I did to my PC. Rest of the components are the same.

PC Components:
  • asrock h270 pro4
  • Asus Strix RX580 8GB (the new "problematic" card) with NZXT Cooling (water) system.
  • Samsung SSD 850 EVO M.2 250GB
  • TOSHIBA HDWD110 - 1TB
  • Intel Pentigum G4600
  • 2x16GB G.Skrill DDR4 2400mhz
  • be quite! 600w
Thanks in advance,
Alex

P.S. I have updated the BIOS to latest firmware (2.10 to 2.60) and SSD has the latest drivers. Let's see.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS