SSD maybe corrupted/broken - wondering if it can be salvaged

May 5, 2018
5
0
10
0
Hi all,
I had an old Dell Precision T7500 workstation from 2012 (Windows 10) that I had been planning to ditch for a new custom built PC. But recently (last week), I started having various issues completely out of the blue (unable to open apps, corrupted files, unable to open anything from desktop etc.). Most of my files are stored on OneDrive so I decided to reset the PC completely, not keeping anything. I redownloaded the majority of apps and programs that I use and this worked for a couple of days. The PC only got to the boot screen (with the windows logo and swirly dots) and it stayed there for hours. I decided to consult the interweb and managed to get the PC to run the self-diagnostics feature, by cutting the power 3 times. I got to a menu with different options so I went to the advanced trouble-shoot settings and ran command prompt. I ran the RegBack directive and all of the numbers were 0. It looked something like this;

01/12/2019 10:57 PM <DIR> .
01/12/2019 10:57 PM <DIR> ..
01/12/2019 10:57 PM 0 DEFAULT
01/12/2019 10:57 PM 0 SAM
01/12/2019 10:57 PM 0 SECURITY
01/12/2019 10:57 PM 0 SOFTWARE
01/12/2019 10:57 PM 0 SYSTEM
5 File(s) 0 bytes
2 Dir(s) 377,040,240,640 bytes free

I was told that if ANY of the numbers were 0 I needed to take the PC (or in this case the SSD) in for repairs. At this point, I decided that the PC had served seven faithful years but its time had come to be replaced with the newer custom built. The SSD (Crucial MX500 - 500GB) was one of the newer parts in my PC and I was going to carry it over into the next build. Now I don't know whether the SSD can be wiped and salvaged - it's corrupted software that is the problem, or whether this kind of error is related to the SSD being damaged or broken.
Any input is appreciated as this could potentially save me a lot of money.
Thanks
 

ASK THE COMMUNITY

TRENDING THREADS