[SOLVED] SSD missing in the bios

Aug 11, 2020
4
0
10
0
I have a gigabyte ga z97x gamer 3 mobo and it has a hard drive in sata 1 and in sata Port 3 there is another hard drive. The new nvme m.2 1tb drive from micron works in windows. I cloned my 500gb OS drive using the acronis tools and I assigned a couple 500gb drive partitions.

The problem is In the bios. Only my sata drives show up In the peripheral menu. When setting boot order only the sata drives show up.

I am running a 2014 bios on this mobo. Updating to a only slightly newer 2015 bios is kind of a hassle. Requires a bootable media due to the 64bit win10

Any suggestions on how to get this ssd hardware to show up in the bios?
 

Turtle Rig

Prominent
Jun 23, 2020
769
103
590
13
This is normal as it is showing your SATA hard disks or SSD drive. The nvMe is totally in a different place, you just have to find it in the advanced BIOS not easy. But it is there and it will not show up in peripheral menu and boot order... As long as your Windows boots up you have no worries. :cautious:
 
Reactions: Solly_501
Aug 11, 2020
4
0
10
0
Hey thanks @SkyNetRising You're correct. Updating to the latest bios for my motherboard fixed it.

I should correct myself too, the actual motherboard and rev that I have is this: GA-Z97X-Gaming 7 (rev. 1.0)

I updated to the F8 (9/18/2015) I Was running the F6 bios from May of 2014. The F6 bios does not properly identify the M.2 slot as a bootable device for this hardware: Crucial NVMe M.2 P1 Solid State Drive (model: CT1000P1ssd8 P3CR013).

I unplugged the two SATA devices temporarily. Then using a different PC, I put the latest bios on a USB stick I had lying around, then booted into bios with that. Using QFLASH, selected update bios from media, it did not show the USB stick, just a blank menu item, hit "enter" on that, which allowed me to browse the USB stick to the updated bios F8 version. After running the BIOS flash, I then rebooted again into the BIOS, and checked the devices, saw the M.2 NVME 1TB drive listed for the first time.

In conclusion, this was worth the effort.
The system was taking 3+ minutes to boot off the old HDD, with the SSD, its booting up in about 30 seconds.

Thanks again.
 

ASK THE COMMUNITY

TRENDING THREADS