Question SSD no longer detected in BIOS after installing windows

Rajon_1

Reputable
Feb 3, 2017
3
0
4,510
0
Hello everyone,

I’m on mobile so please excuse any spelling mistakes but my computer has seen better days.

I bought two SSD’s with my amazon gift cards from Christmas. My pc originally only had a 500 GB 7200 rpm hdd. I installed both ssd’s properly and fastened them both in. I started my PC, found the MP500 drive from Corsair that I want to install windows on. All was well after the install.

Windows was up and running just fine, it had prompted me to restart for hardware changes. I happily obliged. I restarted and it took me to the BIOS because I forgot to set my ssd as my #1 boot priority. But now, my M.2 drive is nowhere to be found? Troubleshooting steps are listed below.

  • disabled csm, didn’t work
  • disabled csm, enabled secure boot with restored keys, didn’t work
  • enabled csm and set both options to legacy instead of UEFI didn’t work
  • disabled xmp, didn’t work
  • booted into windows install media, tried running diskpart and chkdisk commands to see if it even detects it. Neither did
Anyone have any other suggestions?

Edit: forgot specs

MB: Aorus z370 wifi
Ram: hyperx 16 gb ddr4 3200
Cpu: Intel i7-8800k
Gpu: sapphire nitro+ rx580
Storage: Samsung 860 evo (detected) wd 500 gb 7200 rpm hdd (detected) Corsair MP500 M.2 nvme pcie gen.3x4 ssd (not detected)
 

Rajon_1

Reputable
Feb 3, 2017
3
0
4,510
0
Hello sorry for late reply.

it was once again working fine. I’m honestly defeated at this point something just randomly throws it off. I restarted the PC this time around because the mouse was having issues and now I’m right back where I started.

Troubleshooting this time around:

flashed bios to f15a from AORUS site

Reset cmos after bios flash

Tried both m.2 ports on board

Disconnected the sata ssd

Reset cmos again after sata ssd gone

Once again disabling/enabling csm

checked the boards manual. I have a supported ssd according to the manual.

This next point is probably the strangest thing ever but hear me out:

Before this whole mess of crap one thing that inconsistently worked for me was if I had the USB drive with the windows iso media plugged into the PC. It would detect it in BIOS, and I was able to boot off of the drive. Although very inconsistent it sometimes worked. I’ve tried disconnecting and booting, removing and booting again and nothing is popping up.

At this point I’m going to go to Gigabyte support I’m really defeated and I don’t know what’s going on with this.

If you have any other suggestions please let me know I’m open to anything.
 

ASK THE COMMUNITY

TRENDING THREADS