Question SSD not being detected on a new PC build

Feb 1, 2020
2
0
10
0
I assembled the hardware yesterday however when I tried to use the Windows 10 Install tool, it could not detect any Storage Drives when at the step where I select a drive and partition to install on. At this point I booted to the UEFI menu to see if the drive was detected there, which it was not. I tried changing the SATA3 port on the Motherboard as well as the cables and repeated the aforementioned process still to no avail. Next I removed the SSD and connected it to my laptop via SATA/USB cable. The drive showed up as an empty mass storage device on my laptop.
Given these steps, I don't believe the cables, input ports, or SSD are damaged, but I still cannot detect the SSD on the new PC build.

What other things should I do to verify that the hardware is not at fault? If the hardware all checks out, what should I try next?
(EDIT) from ASRock's support page, I see there are two newer versions of the UEFI than what is currently running on my motherboard, I would rather try other options for debugging this issue prior to flashing an updated version as the patch notes do not indicate a fix to this issue.

The hardware I'm using is as follows:
Motherboard: ASRock x570 Phantom Gaming 4 Wifi ax
SSD: Sunbow SATA3 1TB
CPU: AMD Ryzen 5 3600
GPU: AMD Radeon RX 5700 XT

Update:
I have now also used SSD diagnostic tools to verify that the storage drive is in fact healthy and operational. At the same time I used a multi-meter to check the continuity of both SATA3 cables that I have tried. The cables are functioning properly, so neither the SSD nor the SATA3 cables appear to be the issue.
Update 2:
Flashed UEFI/BIOS with the newest version from motherboard manufacturer (ASRock). The only noticeable change in regards to connecting to the SSD is that instead of where the BIOS previously showed an empty list of connected storage drives, it now lists all storage input ports as "Not Present."
This leads me to believe one or more of the following things are the cause of this issue:
  1. The tcsunbow SSD is incompatible with ASRock Motherboards (hopefully the case)
  2. The ASRock Motherboard I am using does not support SATA connections as being the bootable Drive. This seems unlikely as in their support page for this Motherboard there are a decent number of compatible SATA3 SSD's, just none from tcsunbow.
  3. The SATA Bus on the motherboard is not functional for one reason or another and unable to detect any device. (The worst case scenario that I really hope isn't the issue....)
 
Last edited by a moderator:

Lutfij

Titan
Moderator
It might not be an incompatibility issue. We will need a little more information. Ideally you should've listed our specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:

Did you create your bootable installer using Windows Media Creation Tools? To rule out a faulty SSD, try and connect the SSD to a donor system and see if that pops up in BIOS connected devices list as well as Disk Manager.

Might also want to share which BIOS version you've updated to.
 
Reactions: getBendi
Feb 1, 2020
2
0
10
0
CPU: AMD Ryzen 5 3600
Motherboard: ASRock x570 Phantom Gaming 4 Wifi ax
Ram: G. Skill Ripjaws DDR4-3200 16GBx2 (32GB total)
SSD/HDD: TC Sunbow X3-1T (SATA3 1TB SSD)
GPU: AMD Radeon RX 5700 XT
PSU: Corsair TX 550M
Chassis: NZXT H510 ATX Mid Tower Case
UEFI/BIOS Version 2.20 (See ASRock BIOS Support page here) I updated BIOS from Version 1.40 to Version 2.20

Yes, I created the bootable installer using Windows 10's Media Creation Tool.
When I connect the SSD into my laptop using a SATA3 to USB cable, I am able to find it under "Disk Drives" in the Device Manager as well as through DISKPART in Command Line. I am also able to locate the SSD when in BIOS on my laptop. It is identified in BIOS and Device Manager with the same name.

-Thank you
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS