Question SSD not recognized by bios

Jan 24, 2020
1
0
10
0
Hey,

Recently my bios stopped recognizing my SSD when i launch my computer. Whenever i run the computer i get the message "Reboot and Select proper boot device".
if i try and enter the BIOS i find out that the SSD isn't listed there under storage and is not recognized anywhere. I checked the hardware itself and it appears the SSD is still connected.
The SSD is the drive Windows 10 is installed on. I have had this computer for only a couple of months and i have had no other problems so far.

My setup:
Asus TUF Z390-PLUS GAMING (WIFI) LGA1151v2, Intel Z390, DDR4, 2xPCI-E, HDMI, DP
Intel Core i7 9700KF 3.6Ghz 12MB Cache s1151v2
Kingston HyperX Fury Red 2x16GB DDR4 3200MHz CL18 Kit HX432C18FRK2/32
ASUS RTX 2080 DUAL Advanced 8GB GDDR6 HDMI 3xDP USB Type-C DUAL-RTX2080-A8G
Western Digital Caviar Black 2TB 64MB 7200 RPM Sata III WD2003FZEX
Kingston A100 PCIe NVMe 3.0 x2 3D TLC M.2 2280 960GB SSD SA1000M8/960G

What else have i recently done & experienced:
  • Before this became an issue i had a different problem for a few days where the computer will not wake up properly after put on Hibernate/Sleep. The computer itself would wake but nothing appeared on the screen so i had to restart it. Later I started having this booting problem, but i 'played' a bit with some bios settings and it fixed it. Now i reached the point nothing that i do works and i'm stuck without the SSD getting recognized.
  • I don't quite remember but i think before any issues happened i updated windows and also used Driver Booster to update my drivers. I don't know if this is what caused the problems.
Thank you
 

popatim

Titan
Moderator
If you go to install windows, when you get to the"where do you wish to install to" screen, click the Drive options link and is your drive listed there?

or you can use a newer linux live cd and see if it detects the drive.
 

Zizo007

Commendable
Feb 23, 2019
1,373
170
1,440
34
Hey,

Recently my bios stopped recognizing my SSD when i launch my computer. Whenever i run the computer i get the message "Reboot and Select proper boot device".
if i try and enter the BIOS i find out that the SSD isn't listed there under storage and is not recognized anywhere. I checked the hardware itself and it appears the SSD is still connected.
The SSD is the drive Windows 10 is installed on. I have had this computer for only a couple of months and i have had no other problems so far.

My setup:
Asus TUF Z390-PLUS GAMING (WIFI) LGA1151v2, Intel Z390, DDR4, 2xPCI-E, HDMI, DP
Intel Core i7 9700KF 3.6Ghz 12MB Cache s1151v2
Kingston HyperX Fury Red 2x16GB DDR4 3200MHz CL18 Kit HX432C18FRK2/32
ASUS RTX 2080 DUAL Advanced 8GB GDDR6 HDMI 3xDP USB Type-C DUAL-RTX2080-A8G
Western Digital Caviar Black 2TB 64MB 7200 RPM Sata III WD2003FZEX
Kingston A100 PCIe NVMe 3.0 x2 3D TLC M.2 2280 960GB SSD SA1000M8/960G

What else have i recently done & experienced:
  • Before this became an issue i had a different problem for a few days where the computer will not wake up properly after put on Hibernate/Sleep. The computer itself would wake but nothing appeared on the screen so i had to restart it. Later I started having this booting problem, but i 'played' a bit with some bios settings and it fixed it. Now i reached the point nothing that i do works and i'm stuck without the SSD getting recognized.
  • I don't quite remember but i think before any issues happened i updated windows and also used Driver Booster to update my drivers. I don't know if this is what caused the problems.
Thank you
Did you reinstall the ssd when the issue occured? Try to remove and fully reinsert the m.2 ssd straight. Mine wasn't detected because it wasn't fully inserted eventhough the gold part was all in.
 

ASK THE COMMUNITY

TRENDING THREADS