Question SSD not running ?

Oct 29, 2019
3
0
10
0
Hi. I have Kingston Heyberx 120Gb. by mistake I was trying to plug-off SATA cable and break the plastic cover.


Now, when I plug-in the power cable I can't feel or scene any kind of movement in my SSD !! I don't know what to do to solve this ? Please. I need to fix. Any clue, information or device could get my SSD back write it.
 
it might work when slid into a horizontal docking station in a 5.25" bay such as Icy Dock makes... (that was a solution for an Intel SSD with similar broken plastic, could not get connector to stay in place, but, the rigid fit inside docking station worked fine..
 
Oct 29, 2019
3
0
10
0
make sure the connection is tight
I do my best to make it tight.
it might work when slid into a horizontal docking station in a 5.25" bay such as Icy Dock makes... (that was a solution for an Intel SSD with similar broken plastic, could not get connector to stay in place, but, the rigid fit inside docking station worked fine..
But in my case now this will not work. Today I went to several workshops to fix it. One by mistake push in one of those small gold irons "tongues" !!! He did his best to get it back but failed. Anyway, Now I found a guy told me that He may cold make it run back to get a back-up or clone for the all files and then transfer them into new SSD. Or, buy a new/used same the broken SSD and then he will change the replace them. Is this good idea ? Could I send it to the company to fix it ? I'm afraid for my personal details !!
Glue broken piece back in there.
Then use this type of adapter to minimize stress on glued connector.

Good I idea. But now I have to do something different.
 

ASK THE COMMUNITY

TRENDING THREADS