Question SSD not showing in bios boot priority

Oct 23, 2021
2
0
10
0
I have multiple HDD/SSD. Windows 10 is installed in 1 of the Intel SSD(Drive D) and windows 11(Default OS Drive C) is installed in lemex SSD.

I'm able to boot using dual boot. However, in bios, it only shows the Intel SSD as a bootable option. I'm not sure why does it allow me to boot from Lexar SSD with windows 11

How do I enable Lexar SSD in the boot priority in bios?

Disk management


Boot Menu



SSD is showing in bios but not boot menu
 
Last edited:
Oct 23, 2021
2
0
10
0
Presumably you installed Win 11 with all the other drives still connected.
Resulting in Disk 3 having the boot info for both 10 and 11.
I did a clean install of windows 11. In this case what should I do now. I assume if I remove the windows 10 drive it will not boot anymore..
 

bandit8623

Distinguished
Feb 9, 2013
9
0
18,520
1
it sounds like one os was installed using uefi. the other is legacy bios mode.
you can convert a legacy bios to uefi with tools.

https://www.partitionwizard.com/partitionmagic/mbr2gpt.html

after this is done you should see both drive in the uefi boot menu..

the other option is to change you boot mode to legacy only if you want to boot to the non uefi windows, and then go back to eufi only for your uefi os.

my guess is windows 10 is legacy bios and your 11 is uefi.

kinda old school but this is what i mean - https://docs.oracle.com/cd/E23161_01/html/E37044/glsem.html
 

lance88

Honorable
Aug 4, 2015
13
0
10,510
0
Lexar nvme will only appear in bootable if it has win OS installed and its a GPT format

https://docs.microsoft.com/de-de/windows/deployment/mbr-to-gpt?ranMID=46131&ranEAID=kXQk6*ivFEQ&ranSiteID=kXQk6.ivFEQ-HYF4.x9QUSSl6AxR2Zv4Jw&epi=kXQk6.ivFEQ-HYF4.x9QUSSl6AxR2Zv4Jw&irgwc=1&OCID=AID2200057_aff_7806_1243925&tduid=(ir__tiiqswk92ckf60gaiyumtzj9rf2xra91rkcamwya00)(7806)(1243925)(kXQk6.ivFEQ-HYF4.x9QUSSl6AxR2Zv4Jw)()&irclickid=_tiiqswk92ckf60gaiyumtzj9rf2xra91rkcamwya00

Checks if your drive is MBR format

Follow the link to convert MBR to GPT, you will need to use /allowFullOS to work.

You can specific the disk number if its not 0. Eg, mbr2gpt /validate /disk:0 /allowFullOS

Once completed, restart and boot immediately into bios page and change boot mode to UEFI and viola.
 

ASK THE COMMUNITY