Question SSD not showing up as boot device

Sep 30, 2020
3
0
10
0
Hello guys,

I have a PC with a SSD and HDD built in it. When I bought the SSD I did a fresh Windows installation on my SSD and set it as boot device. Today I updated my BIOS drivers and the default BIOS settings were applied. The first time after the driver update my PC started normally, everything worked perfectly. I shut it off without complaints. Now I wanted to start my PC again and got an error message saying 'Reboot and Select proper Boot device'. I went to my BIOS and looked under the boot options. Under the Priority Order I can't see my HDD or SSD. But if I go to 'Advanced'>'Miscellaneous' I can see my HDD under SATA Port0, my SSD under SATA Port2 and my DVD-Drive under SATA Port4.
I can remember that when I ordered my SSD i already had this problem of my SSD not showing up under the boot devices. But I read somewhere to disable/enable some options in the BIOS, I did it, and it worked. But I just can't find this Thread/Comment anymore.
When I change the settings Secure Boot=Disabled and Launch CSM=Always the only device that gets shown under boot device is my DVD-Drive....
My PC is an ACER Predator G3620, BIOS is from American Megatrends.
Does somebody know the answer to my problem?

Thank you.
 
First thing I'd do is clearing CMOS.
To do that you'll need to open your case and pull out the CMOS battery for ~20 minutes. After that just put it back in(with the correct polarity... + sign up) and start your system.
 
Sep 30, 2020
3
0
10
0
First thing I'd do is clearing CMOS.
To do that you'll need to open your case and pull out the CMOS batter for ~20 minutes. After that just put it back in and start your system.
Ok, thanks. I'll try that right now.

EDIT: Didn't work...
 
Last edited:
Make sure that in your BIOS the SATA controller is enabled and SATA mode is set to AHCI.
Leave Secure Boot disabled.
Have you tried both enabling and disabling CSM(what are the differences when switching between them)?
Are you sure that all your drives are plugged in properly?
 
Sep 30, 2020
3
0
10
0
Make sure that in your BIOS the SATA controller is enabled and SATA mode is set to AHCI.
Leave Secure Boot disabled.
Have you tried both enabling and disabling CSM(what are the differences when switching between them)?
Are you sure that all your drives are plugged in properly?
I restarted my PC several times and suddenly it worked again....I have zero clues to what happened and why it works again....still thanks for your help!
 
I restarted my PC several times and suddenly it worked again....I have zero clues to what happened and why it works again....still thanks for your help!
Well, looks like that motherboard has some issues though since you said it was doing this before with the other BIOS version.
Strange problem since your BIOS configuration was fine and everything was plugged in correctly.
Hope that'll work fine from now on, but beware that the problem might reoccur if there's indeed a problem with the board(likely by the looks of it).
 

ASK THE COMMUNITY

TRENDING THREADS