[SOLVED] SSD problem (can't format, install windows but I can read data, SMART, etc)

Oct 27, 2019
Hi there!

I need help with my ssd drive Goodram cs400 512GB which I bought one month ago. On friday this week I turned on my PC and couple of minutes after I logged in I've got bluescreen (inaccessible boot device) I tried using windows 10 repair tool from usb but it doesn't work. I can't install new Windows on any partition (0x80000010 error code) I have also tried to disable write protected in diskpart but it didn't help. I've tried to connect disk to another pc via USB and I have access to every data on the disk, HDTune tells me that it isn't any bad sectors, I can read SMART by 'cristal disk info' program it tells that everything is ok. but when I try to format disk via diskpart, right click -> format, mini tool partition wizard I always get message that format passed correctly. But nothing changed, every data is still on disk. I can install and deinstall new soft or copy images etc, but data before crash is undeletable.
Do you have any idea, what can I do with that problem?

Take care,