Question SSD Randomly fails, doesn't show up under BIOS, then randomly pops back up

brreaker

Distinguished
Oct 15, 2012
19
0
18,510
0
So, a couple of weeks ago, I get home and see my PC turned off. Okay, sometimes it happens, maybe the cat got on the keyboard or pressed the wrong button. So, as usual, I go to turn it on only to be greeted by "Insert boot media and press any key".
Hm, that sometimes happens, I don't know why but BIOS likes to switch around my two SSDs in the HDD order, so I go back into BIOS, switch them around, restart and.... Nothing. It just stays there, doing nothing.

Mmmkay, I can maybe accept that Windows got corrupted (who hasn't gotten screwed over by a random update...) so I pop my trusted USB stick, boot windows installer and.... My drive shows up as "Read only". Huh, interesting.
I boot up CMD, chkdsk, it finds some errors and... Couldn't be fixed, drive is read only.
I run disk part and the drive doesn't show up. At all. I restart and it's gone.
Took it out of the PC, mounted it as an external disk (USB 3.0), still not showing up.
I accept that my SSD has died and wait until I can find the time to go get another one.

Fast forward to yesterday; got a new disk, popped in my trusty USB and... What? 3 disks?
The old one shows up even though it says "Total space 238 GB/ Free space 238GB" and "Windows cannot be installed on this drive".

Okay, I try to install it on the other one, same thing happens, so I gotta go back into CMD, go into disk part and convert it to MBR. Fine, I can finally install windows.

I boot up windows, go into My PC, disk nowhere to be found. Go into Disk Management, it shows up and asks me to define the partition. FINE. Set it up, shows up under my PC but Windows says I have to format it before being able to use it.

sigh, I format it, get some recovery software from a friend, couldn't recover ANYTHING at all except a couple of images from a Program Files folder.

I downloaded the kingston SSD Manager, Under health everything shows up fine, except one bar that says "Uncorrectable errors: 1".

So, I'm running three Kingstons right now. This one is the third one failing me in two years; first one I brushed as bad luck, second as jynx, now I'm getting pissed.

Another drive I've got for years, Kingston as well, works like a wonder! Only thing, it's never had Windows on it. Only the ones that had Windows on failed me.

So, long question short: is there any known problem with Kingston SSDs and Windows? I can't seem to find anything and I'm going crazy.

Current disks:
The new one - KINGSTON SA400S37120G - 431 Power On Hours (Installed it yesterday, so at most 12h run time, the rest... your guess is as good as mine)

The failing one - KINGSTON SA400S37240G - 4944 Power hours. Manager says No failures, no warnings and overall healthy. Uhm.

Third drive, the one that never failed,
KINGSTON SV300S37A240G - Power on hours 23976 (now this is a lengthy disk!) and working as well as always.

Obligatory, running Windows 10 Pro x64, AMD FX 8350, 24 GB RAM on an ASUS M5A78L-M Plus USB3

Thanks a bunch!
 

Ralston18

Titan
Moderator
Have there been any known power outages in your area? Especially if there are frequent outages or brownouts?

Have you tried swapping in known working SSD cables (data and power)?

Make and model PSU? Wattage, age, condition?
 

brreaker

Distinguished
Oct 15, 2012
19
0
18,510
0
Well, now that you mention it, I think there's been maybe 4-5 outages in the past two months, due to weather conditions. Do you think a power outage would be able to do that much damage nowadays? I mean I know some years back they were a real problem, and I remember blown PSUs from back then, but not so much nowadays

I did swap cables as well as ports, seems to be the same in all of them.

PSU is 650W, around one and a half years old, can't remember make/model on the fly, unfortunately.

As soon as I get home (I hope to remember at least) I'll update the PSU info.
 

ASK THE COMMUNITY

TRENDING THREADS