Question SSD showing up in BIOS as boot device but doesn't boot; ''Reboot and Select proper Boot Device'

Apr 1, 2020

I was updating my NVIDIA Geforce driver and all of a sudden my computer shutdown and reset and ever since it won't boot. I keep getting the message ''Reboot and Select proper Boot Device or Insert Boot Media in selected Boot device and press a key." I checked my BIOS and my SSD, HDD and CD-ROM are listed there and SSD is set to boot priority. I checked the details for my SSD and HDD in BIOS and its shows up the correct storage space so I believe there is nothing wrong with the SSD

What is known/I have done so far but hasn't helped:

- changed my sata ports for my SSD and HDD (SSD is where my windows is installed)

- tried only plugging in SSD port

- BIOS detecting both my drives and SSD is set as Primary Boot Device

- BIOS showing how much space SSD has when checking for details

- Tried using external bootable device but still gives the same message

- changed CMOS battery

- Tried booting from a bootable USB but even that is not being detected

I don't know whats wrong or where to find a solution. It's been a month and its very frustrating that I still haven't found a solution. I have looked on google and YouTube but nothing has helped.

Motherboard: ASUS M5A78L LE R2.0 Socket AM3+ AMD 760G Motherboard ATX DDR3

OS: Windows 10
Last edited: