Apr 15, 2019

I built a new computer, works fine until the moment I tried to start the machine.

I have an 128GB kingston SSD which is connected via a SATA cable to the motherboard (ASUS prime z390A) and has power supply. The SSD is the same I used in my previous computer. The problem I encounter is that when start up (would be the first start up, so installation of windows etc is needed) I am send to the BIOS. Here I can see that all my hardware, including the SSD is recognised.

However in the boot menu I only see my bootable USB (containing the windows files) but not my SSD. After a bit of searching I came to secure erase and there it shows that the SSD is frozen.

I have tried to erase it, the computer said it needed a restart in order to do so. When the restart was done, the status of the SSD was "Ready" however after the secure erase it immediatly goes to "Frozen" again.

So my question is, how can I get the SSD unfrozen? As well as how can I get further than the BIOS (if I quit the BIOS the computer restarts just to re-enter the BIOS...) I think that from the moment my SSD is unfrozen I might be able to get past the BIOS but not quite sure.

Did a couple of builds before and never had such a problem.

Thanks in advance,