Question SSD stopped working but still recognized?

Dec 12, 2019
1
0
10
0
My SSD is very new. I installed it less than a month ago. I have the Western Digital 500GB NAND BLUE. It was working fine, I put a couple files on it (kept windows installed on my other SSD) nothing crazy just used about 100Gb. This was doing fine and worked as it should have. Suddenly the SSD stopped working. My computer still boots into my OS (windows 10). HOWEVER, it boots EXTREMELY slow. I'm assuming that this is because it is trying to read that SSD and failing over and over again since when I have the SSD removed it boots as it should. When in windows, I can get to the file explorer and see the drive letter there but explorer.exe usually stops responding by the time i get there. The drive doesn't show any data, just that it's there. I checked DISKPART which also sees it (after long waiting times). So this is recognized to be a storage container but I'm not sure what could have broken? checked the data cable and power to the SSD and those seem to be fine. tried formatting with DISKPART and the quick format on windows, both of which froze. At this point I just want to know what could have happened since nothing else seems to work. In terms of returning it to the seller (NewEgg) they say it must be in its original packaging which I threw away after this incident.
 

ASK THE COMMUNITY

TRENDING THREADS