[SOLVED] Standard NVM Express Controller driver error m.2 ssd not detected

ThaSpoda

Reputable
Nov 2, 2019
32
0
4,540
0
So at the moment I have two m.2 SSD's installed in my pc. The 250gb one is what I am currently using. However, I want to use a Corsair mp510 2tb gen 3 m.2 as well but it cannot be detected in BIOS or Windows. Then I looked in device manager and the Standard NVM Express Controller driver states this error:
This device cannot start. (Code 10)
An I/O adapter hardware error has occurred.
How can I try and fix this? I spent days trying to get the SSD to work after building the pc, until I decided to get another m.2 to install windows onto. The motherboard is an x570s tomahawk max WIFI. Also I am sure it's an issue with the SSD as it didn't work in the other m.2 slot either.
 

Lutfij

Titan
Moderator
What BIOS version are you working with on your motherboard? Processor on your motherboard? Might want to also state which slots the M.2 SSD's are populating on the motherboard.
 

ThaSpoda

Reputable
Nov 2, 2019
32
0
4,540
0
What BIOS version are you working with on your motherboard? Processor on your motherboard? Might want to also state which slots the M.2 SSD's are populating on the motherboard.
Latest BIOS for the mobo
Amd 7 5800x (No raid drivers)
I tried using both slots to no luck only one is "active"
 

ThaSpoda

Reputable
Nov 2, 2019
32
0
4,540
0
7C84v1B
Is what you've stated above, here.

Per this support link for the motherboard;
7D54v10, 7D54v11, 7D54v12, 7D54v13, 7D54v14
are the only BIOS versions listed.

Now;
it does show the version
???
i had the wrong bios but the solution wasn't that it was a corrupted driver directly associated with the m.2 having it replaced is the only solution
 

ASK THE COMMUNITY