Question Star Wars Battlefront 2 horrid load times even with SSD

Jan 8, 2021
6
0
10
0
Pretty much my battlefront 2 load times are horrid and never used to be like this. I decided to play the game again and to my surprise when I was booting it up it took over a minute to get into the menu screen. Needless to say, I moved the game over to my SSD and restarted my pc, it still took over a minute to load. I uninstalled and reinstalled the game, it still took over a minute to load. I restarted my router, still the same thing. Once I do get finally get into the menu screen I booted up an instant action match and it took the map like a minute to load as well. I'd understand this is a DICE game but even these load times are terrible for SSD it makes no sense. I swear to god it never used to be like this my load times were much shorter and faster. Any shed of light on this I would greatly appreciate.
 
Jul 14, 2020
41
1
45
2
What kind of SSD are you using (sata or NVME)? I would also like to point out that when you run the game for the first time after a boot straight from shut down it seems to take a little longer than from sleep so that may be why. It may also be because of internet speed but you were playing offline so it's pretty unlikely. When was the last time you played (like which update). There's a lot of other reasons that could be causing your problem like other things running in the background but I'm not very knowledgeable in those. I personally play too and on first play after bootup it always takes about 15 seconds to load, but from sleep I'm in within less than 30 seconds and I have an NVME ssd.
 
Jan 8, 2021
6
0
10
0
Sorry for late reply I am at work, I’m running a Sata SSD (Samsung evo 860). And as far as the last update, it’s been months since I played I think I played when the last major update was released other than that, I can’t say too much else. The only background apps I run are steam, Spotify, discord and that’s it. I booted it up several times today after starting of from shut down and I got all the same results. Honestly I have no clue what it is but I’m pretty sure it’s not hardware related.
 
Jul 14, 2020
41
1
45
2
Sorry for late reply I am at work, I’m running a Sata SSD (Samsung evo 860). And as far as the last update, it’s been months since I played I think I played when the last major update was released other than that, I can’t say too much else. The only background apps I run are steam, Spotify, discord and that’s it. I booted it up several times today after starting of from shut down and I got all the same results. Honestly I have no clue what it is but I’m pretty sure it’s not hardware related.
Try running task manager or something like that next time your in game and see if anything is hogging your performance. Also, if your running at ultra or high settings it will have some impact on your load times compared to low or medium. Honestly though 1 minute still isn't that bad from my point of view. Sure it's no pcie 4.0 nvme ssd but for sata and especially compared to hard drives (my old pc took 10 minutes to load battlefront 2) it's not that bad.
 
Jan 8, 2021
6
0
10
0
Try running task manager or something like that next time your in game and see if anything is hogging your performance. Also, if your running at ultra or high settings it will have some impact on your load times compared to low or medium. Honestly though 1 minute still isn't that bad from my point of view. Sure it's no pcie 4.0 nvme ssd but for sata and especially compared to hard drives (my old pc took 10 minutes to load battlefront 2) it's not that bad.
Oh well I understand that, but even having this game installed on my HDD it still didn’t take this long and now I have the game installed on my SSD so I’m just very confused as to why this is happening. Also I run this game in medium to high settings, everything runs smooth in game and I’ve been running those graphical settings for forever now. When I get home I’ll try that and come back to the thread when I have done it, I’ll also give you an exact amount of time I’m waiting for the game to load and the maps as well.
 
Jul 14, 2020
41
1
45
2
Oh well I understand that, but even having this game installed on my HDD it still didn’t take this long and now I have the game installed on my SSD so I’m just very confused as to why this is happening. Also I run this game in medium to high settings, everything runs smooth in game and I’ve been running those graphical settings for forever now. When I get home I’ll try that and come back to the thread when I have done it, I’ll also give you an exact amount of time I’m waiting for the game to load and the maps as well.
Lol loading any game on a hard drive in a minute is something I haven't heard very often. Also remember some maps are much larger and require more assets to be loaded Ex: The MC85 is a really small map but Mos Eisley, Geonosis, and Scarif are huge.
 
Jan 8, 2021
6
0
10
0
Lol loading any game on a hard drive in a minute is something I haven't heard very often. Also remember some maps are much larger and require more assets to be loaded Ex: The MC85 is a really small map but Mos Eisley, Geonosis, and Scarif are huge.
approximately 2 minutes to load into the menu screen for both HDD and SSD. I don't care it takes two minutes for my HDD but for SSD? Doesn't make any sense there should be some difference at least 20 seconds or so but there is no difference at all. I also checked my task manager, there are no other programs causing my disk usage to be high it stays at 3 percent in idle. Seems to be no background apps interfering with the fact that I cannot load into the menu screen in under two minutes. Like I said, seriously have no clue, unless you or someone has any other suggestions I'm most likely going to be factory resetting soon to see if that will help.
 
Jul 14, 2020
41
1
45
2
Maybe making sure all my drivers are up to date? I might do that before I reset but as I said, I don't have too many ideas.
Yeah I'd say try that first, but honestly I'm just at a loss at this point mate, never seen this happen to me at all. Good luck, and may the force be with you.
 
Jan 8, 2021
6
0
10
0
SOLVED?: So pretty much after factory resetting my pc and updating GPU driver, it works fine. I have no clue as to what the problem was all I know was that factory resetting my pc did the trick. I'm disappointed with the fact I had to do this and I can't find any other solution to my problem but yea.
 
Sep 20, 2020
70
8
45
1
SOLVED?: So pretty much after factory resetting my pc and updating GPU driver, it works fine. I have no clue as to what the problem was all I know was that factory resetting my pc did the trick. I'm disappointed with the fact I had to do this and I can't find any other solution to my problem but yea.
Did you check if DX12 mode was enabled? If it was you would get bad load times and gameplay regardless of your drive...
 
Feb 20, 2021
1
0
10
0
For me, the appalling load times were accompanied by a lot of disk grinding, which was curious since the game is installed on an SSD. I assumed this must be a virtual memory problem on my 8GB machine. I changed the virtual memory to 16GB on a spare 60GB SSD that I wasn't using, and the load times, while not amazing, are completely acceptable.
 

ASK THE COMMUNITY

TRENDING THREADS