Star Wars Dark Forces 2 Jedi Knight (& MoTS) on Windows 8

TSBroich

Honorable
Nov 12, 2012
9
0
10,510
I am in need of some help here. I have a gaming desktop computer running Windows 8 Pro, and a Samsung 500T tablet running Windows 8.

So far games have been great, but I cannot figure out how to run two particular games on Windows 8:

- Star Wars Dark Forces 2: Jedi Knight
- Star Wars Jedi Knight: Mysteries of the Sith

Neither of these games work at all, when I can play Jedi Outcast and Jedi Academy on both my desktop and my tablet without any problems.


I have both the Steam version of these games, and the original CD's of the games. I've tried creating a post on the Steam game forums, but to my surprise (sarcasm), my post was completely ignored, so I thought I'd try here.

I can find hardly anything online for help on this. All that's said is to try compatibility mode, and I did! I see screenshots of the game running on Windows 8, and people saying that compatibility mode fixed it, not for me! I also tried re-downloading, using Steam version and original CD version, but nothing will work! It will act like the game is launching, then just do nothing...

If anybody here could give me advice that would help me get these games running, I'd greatly appreciate it. If any more information is needed, I will provide it. Thank you again.
 

TSBroich

Honorable
Nov 12, 2012
9
0
10,510


Thank you. Here is a list of all of the things I had tried at the top of my head:

- Run .Exe as administrator
- Run shortcut as administrator
- Add windowgui & displayconfig fix to the end of the shortcut "target"
- Run in maximum window mode from the shortcut
- Reinstall game from original CD
- Redownload game from Steam
- Download the ddraw.dll file and add it to the directory
- Run in compatibility mode with ALL of the different Windows options (95/XP, etc)
- Download all DirectX versions from Microsoft
- Tell shortcut to open game in 640 x 480 resolution


None of these things have done anything to address this problem. It still just does nothing upon opening the game, every single time.
 

pjg

Distinguished
Oct 10, 2012
835
0
19,010
shortcut are the wrong compatibility the shortcut is just a shortcut

so what you do is you go into task manager how to get there you can hold down ctrl+alt+delete there should be a task manager there click on it and it should open up now in task manager go to processsers look for the game in processsers and right click on the game and then properties, compatibility 95 98 xp all that now if this does not work then you can download a "windows 95 window mode"
 

TSBroich

Honorable
Nov 12, 2012
9
0
10,510
Honestly, can you please just stop replying. I appreciate your effort, but I really don't think you understand the problem I'm experiencing.

The game will not start up at all. Nothing happens.
 

pjg

Distinguished
Oct 10, 2012
835
0
19,010



i have nothing to do all day so now i had the same problum with some of my games like it well i got another External cd dvd drive some how it worked. i remember now i think