Question Static sound from my PC speaker

Sep 24, 2020
35
0
30
0
Hey everyone
So I have a PC with windows 10 and I tried 2 speakers with it and with both of them there is this veeeery annoying static sound..
So I tried everything I could find online to try and fix that by myself but unfortunately without any success..
Some of the methods I tried is: updating drivers ( I bought DriverMax and updated 16 drivers). changed sound settings, tried different ports, shut off any smartphones devices around, tried disconnecting the Wi-Fi cables of the motherboard, etc...
and NOTHING helps !
I know that I have another issue with my PC which is something like rattling noise coming out from my PSU, so maybe I need to wait until I will fix that issue first ?

*I connected the speaker to my laptop and the static noise was gone ..

Is there any test that I can do to see if the problem is 100% sure is because of my motherboard ?

Thanks a lot for any help !
 
Hey everyone
So I have a PC with windows 10 and I tried 2 speakers with it and with both of them there is this veeeery annoying static sound..
So I tried everything I could find online to try and fix that by myself but unfortunately without any success..
Some of the methods I tried is: updating drivers ( I bought DriverMax and updated 16 drivers). changed sound settings, tried different ports, shut off any smartphones devices around, tried disconnecting the Wi-Fi cables of the motherboard, etc...
and NOTHING helps !
I know that I have another issue with my PC which is something like rattling noise coming out from my PSU, so maybe I need to wait until I will fix that issue first ?

*I connected the speaker to my laptop and the static noise was gone ..

Is there any test that I can do to see if the problem is 100% sure is because of my motherboard ?

Thanks a lot for any help !
Yes, electrical noise in PSU can do that.
 
Sep 24, 2020
35
0
30
0
Hey everyone again, So I changed my power supply to a new one and the rattling noise the PSU had was gone.
Unfortunately it didn`t fix the speakers problem/headphones problem..
Again I tried any troubleshooting I could.. at least that is what I think so..
Anyways, a friend of mine said that maybe the first building I did may have gone a little bit wrong because I had couple of issues with my new PC already. So he said something about the minus and plus that are on the motherboard, maybe we put it wrong? is this an option in your opinion? can you please help me understand where should I look at on the motherboard itself?
Maybe it is a bios thing ?

Guys, thank you very much for anyone who reading this and want to try and help me with that :)

This is a Z390 Aorus Pro Wifi

Im adding a live video of this annoying terrible noise lol

View: https://imgur.com/gallery/ET0OG1V?s=wa
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS