Question Stop code 0x000021a happening literally every now and then. Don't know the cause. Tired of resetting Windows.

Serban_2

Honorable
Jun 7, 2016
6
0
10,520
1
Specs:
i3 4170
RX 580 8GB
GA-H81M-S2PV motherboard
2x4GB RAM 1666mhz
1TB WD HDD
256GB Kingston SSD
Corsair CV650

First time I got this error was a few weeks out of nowhere. I used system restore and it worked fine after. Then only after a few days it came again, and this time system restore did not work. I had to reset my PC. Fast forward today I tried updating Windows and on boot up I got this error again.

I don't want to reset Windows every week so I want to know what's going on. Going into safe mode SrtTrail.txt it says the root cause is "A recently serviced boot binary is corrupt."

Windows troubleshoot tool didn't let me undo any updates. The log files said something about deleting LCU files and failing so I deleted them myself and of course that's stupid it didn't work.

Last time I had this I did /sfc scannow and /chkdsk but none worked, so I'm not gonna bother with them this time too.

I used a recent system restore and my PC DIDN'T work this time after. This is getting very annoying and I can't pinpoint the exact cause. All my components work fine, I game fine, I browse Windows fine, my hard drive works, my SSD works, I checked both their health, I checked my RAM for corrupt sectors and it didn't report back any errors, haven't had any real issues with my GPU. So what's the damn cause?

A few maybe unrelated things that might help, iTunes has trouble connecting to my iPhone, although I'm certain my cable is fine.
When I first booted into safe mode it said that "the update was unsuccessful" and it tried reverting, restarted, then I went in again and it immediately restarted again, and then it finally worked. When I updated Windows today I walked away so I didn't see anything but assuming the update failed, why? I didn't shut down my PC and there was no outage.
Windows troubleshoot told me the log files were in D drive but I don't have a D drive. I checked my C drive and the log file had today's date.

edit: as a quick update this time it's even worse, reset didn't work, I'm reinstalling Windows via usb.
 
Last edited:
hi, if it happens again,, reboot 3x pc during boot, this would give you recovery boot menu or boot from usb media
select troubleshoot -> advanced options -> startup settings -> restart
boot menu will appear, select F7 option (disable driver signature enforcement)
if pc boots with this option, then run this command in powershell/cmd/windows terminal with admin rights (any command-line tool you have):
bcedit /TESTSIGNING OFF
 

ASK THE COMMUNITY