Storage not detectet after rebuilding system (HDD,SDD)

May 27, 2018
21
0
10
0
Hello,

I just disassembled my system to modify my loop and change the PSU, power cables and the SATA cables. (One for the HDD, the other one for the SSD) There is also a M.2 SSD.
After rebuilding the system, the boot screen (Press F2 to enter BIOS) appeared for very long time (1 - 2 minus)
In the BIOS I saw, that the system not detect any of my 3 storage devices. The M.2 SSD was never detected... But it worked and still works now, I can load Windows.
But when i disconnect the SSD the boot screen just stays for about 5 seconds. But still gets not recognized.

I have no clue and i checked the following things:
1. Default Settings in BIOS
2. Checked SATS Controller
3. Changed the SATA cables with some spare ones.
4. Checked if there are any conflicts between the lines due to the M.2 SSD.
Before disassembling the system I used the same ports. Therefore, i didnt try port 3/4.

Does anyone maybe have an idea why the storage doesnt get recognized and why it takes so long to boot when the SSD is connected?

Here my specs:

Case: Fractal Nano S
Mobo: Asus Strix Z370I
CPU: Intel i7 8086K
GPU: EVAA GTX 1080ti SC2
RAM: 32 GB G.Skill Trident Z 3200Mhz
PSU: Silverstone 800 Watt
M.2 SSD: Samsung Evo 960 265GB
SSD: Intel 545's 256 GB
HDD: Seagate Barracuda 4000 GB


And I'm sorry if the text isn’t grammatically perfectly correct. I'm doing my best :)

Best regards

UPDATE: I also connected an other HDD to Sata Port 3. Didn't work too.
I also noticed, that the HDD doesn't even start turnung. But I know the HDD's work and i also know the cable gets power...
 
One of the main functions of the BIOS is to establish the Boot Order. I'm wondering if you may have changed the SATA connectors on the motherboard (or the order on the SATA data cable ) when you changed the cables. If you did so you would essentially be changing the address of the drive. And therefore the BIOS is confused on the drives for the boot order.

Try unplugging the SATA data cable from all drives except the system drive. Then reboot and enter the BIOS, and designate that drive as the first drive in the boot order and then exit saving changes.



Then one at a time repeat the process adding drives one at a time (maybe changing the cabling order of the SATA data connection). If it finds it, then add it to the boot order and exit saving changes. Then repeat until you have your drives identified.

I would check out the drives in Disk Management, but especially the M.2 SSD. I am guessing that there is something odd about it's configuration. If nothing else works, then transfer its data to another drive (you said it still works). Then reformat the drive, and then partition the drive as if it were a new drive.
 

ASK THE COMMUNITY