Question Strange 4K60 timing issue

Radius

Distinguished
May 6, 2004
6
0
18,510
0
Can't for the life of me figure this out. Google has not been much help.

So I have a Lenovo M93p tiny PC. It's a great little machine and I love the thing. It is getting older though, but still works great with one exception. I am using it in my HT setup as a general purpose HTPC as well as using it to configure my MiniDSP and a few other things.

I can't get 4K60 to work properly on it. It has an i7-4765T with 4600 integrated GPU. As for ports it has VGA, HDMI and DP. The specifications for this little box state that it will support 3840x2160 @ 60hz on Display Port only. Max out of the HDMI is 1080p. So I am using a Monoprice DP to HDMI active adapter.

I cannot select any default refresh than 30hz. However, if I use the Intel GPU utility, I can create a custom resolution of 3840*2160 @ 60 Hz using CVT-RB timing.

This works and I get 4K60 on my display. The issue is that it running this resolution at 533MHz. This is playing hell with some of my gear with requires VESA timing which is 597MHz.

I suspect the 533MHz timing is due to using CVT-RB. However if I try any other timing option while creating the custom resolution I get the dreaded "This custom resolution exceeds the maximum bandwidth capacity" error.

I have 3 different 18Gbps rated cables I have tried. All 3 work when using a verified 4k60 444 source. So I don't think it's a problem with the cables.

I have one of each of these adapters. For the life of me I can remember which one I am using. One didn't work at all and the other is the one I am using now:

https://www.amazon.com/gp/product/B073XPTBDD
https://www.amazon.com/gp/product/B07FPQ4ZSW

I investigated CRU and tried to do something with it. I either don't understand what I am doing or it did not work. Or both? :)

Since I suspect this might be an adapter issue, I also ordered one of these which is a recommended adapter by the author of CRU but it hasn't arrived yet:


Any advice on getting this to work properly? Am I missing something?
 

ASK THE COMMUNITY

TRENDING THREADS