Question Strange FPS Drops

Aug 20, 2020
5
1
15
0
Hey guys,

I recently bought a 1660 ventus and put it in my computer, things were running well games looked fantastic but my PSU wasn't able to handle and would cut out sometimes.
So I basically built a full new PC with specs as follows:

Motherboard: MSI B450 Tomahawk Max
PSU: EVGA 650W SN G3 Gold PSU
CPU: Ryzen 5 3600x - Notcua NH-D15 (Cooler)
RAM: Corsair Vengeance RGB PRO 16gb
GPU: MSI GTX 1660 Ventus XS 6gb

Now my monitor is 60hz and I often have to use v-sync or I get some bad screen tear.
These games such as GTA/COD should run perfect at 60fps with no drops v-sync on but for some reason my frames drop from 60 to low/high 50's (VSYNC IS ON) which doesn't sound bad but it feels insanely terrible.

I've tried lowering settings on games but nothing seems to help, it's always the same lil frame drops from 60 to 57ish and back up to 60.
GTA/COD ran perfect on my old PC which had way worse specs but with the same GPU but on this PC which is vastly better something is different. Also tried re-installing drivers etc nothing seems to help.

AND I also tried some Nvidia settings in control panel such as adaptive and triple buffering but none of those seemed to help.

Any possible solutions are welcome, thanks.
 
Reactions: UserAccountnum1
Aug 20, 2020
2
1
15
0
Hey guys,

I recently bought a 1660 ventus and put it in my computer, things were running well games looked fantastic but my PSU wasn't able to handle and would cut out sometimes.
So I basically built a full new PC with specs as follows:

Motherboard: MSI B450 Tomahawk Max
PSU: EVGA 650W SN G3 Gold PSU
CPU: Ryzen 5 3600x - Notcua NH-D15 (Cooler)
RAM: Corsair Vengeance RGB PRO 16gb
GPU: MSI GTX 1660 Ventus XS 6gb

Now my monitor is 60hz and I often have to use v-sync or I get some bad screen tear.
These games such as GTA/COD should run perfect at 60fps with no drops v-sync on but for some reason my frames drop from 60 to low/high 50's (VSYNC IS ON) which doesn't sound bad but it feels insanely terrible.

I've tried lowering settings on games but nothing seems to help, it's always the same lil frame drops from 60 to 57ish and back up to 60.
GTA/COD ran perfect on my old PC which had way worse specs but with the same GPU but on this PC which is vastly better something is different. Also tried re-installing drivers etc nothing seems to help.

AND I also tried some Nvidia settings in control panel such as adaptive and triple buffering but none of those seemed to help.

Any possible solutions are welcome, thanks.
I'd open task manager, make sure you're in a game with only yourself (aka singleplayer) because without 2 monitors you cant watch 2 things at once while gaming in fullscreen. When a frame lags and tears check task manager for anything like cpu, ram, gpu, or whatever else you may suspect to be the culprit, I'd recommend watching all, but this may not solve your issue. I would check your monitor for any settings like AMD's freesync or better yet, G-Sync. (since you have a gtx1660 which is nvidia) I dont have screen tearing in any of my games and i have a far worse build, with an i3 9100f and an rx560, which should be performing worse.
 
Aug 20, 2020
5
1
15
0
I'd open task manager, make sure you're in a game with only yourself (aka singleplayer) because without 2 monitors you cant watch 2 things at once while gaming in fullscreen. When a frame lags and tears check task manager for anything like cpu, ram, gpu, or whatever else you may suspect to be the culprit, I'd recommend watching all, but this may not solve your issue. I would check your monitor for any settings like AMD's freesync or better yet, G-Sync. (since you have a gtx1660 which is nvidia) I dont have screen tearing in any of my games and i have a far worse build, with an i3 9100f and an rx560, which should be performing worse.
I had a look while I was online in GTAV, everything in task manager seemed to be normal, nothing is running hot or anything. GPU however sits at around 16% utilization, should that be higher do you think or am i just clutching at straws here.
 
Aug 20, 2020
5
1
15
0
I checked with more reliable programs as well like afterbruner and cpuz etc and everything seems fine, to me it feels like something is bottlenecking the GPU but all the specs are fine and shouldn't be having this problem at all.

I tried disabling HPET and some other things like game boost on and off but nothing helped.
It should be noted no matter what the game, changing graphics settings high or low doesn't seem to help the problem.
 
Sometimes you will get fps drops when locking to a certain framerate. High 50's I wouldn't worry. Do you really notice the difference? The GPU isn't running at full power when Vsync is on. So therefore there will be some variation in the FPS. If you want something more consistently at or above 60 and can't stand the tearing you'll need to go high refresh rate.
 
Aug 20, 2020
5
1
15
0
Sometimes you will get fps drops when locking to a certain framerate. High 50's I wouldn't worry. Do you really notice the difference? The GPU isn't running at full power when Vsync is on. So therefore there will be some variation in the FPS. If you want something more consistently at or above 60 and can't stand the tearing you'll need to go high refresh rate.
When it drops from 60 to 50s so consistently yeah it's super off putting but here in lies the problem, even if I disable V-sync my frames are still dipping down, in pretty much any games regardless of ingame graphics or resolutions.
 

ASK THE COMMUNITY

TRENDING THREADS